Sequelize version 5 before 5.3.0 does not properly ensure that standard conforming strings are used.
Priority LOW 36CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
Sequelize version 5 before 5.3.0 does not properly ensure that standard conforming strings are used.
Why it matters now
EPSS 0.01823 78th percentileScored 2026-11-07
Fix Fixed sequelize (npm): 5.3.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | sequelize (npm) | 5.0.0 to before 5.3.0 | 5.3.0 | Patch available | GHSA-2777-2vq8-c4v4 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- sequelize (npm) Vendor— Affected 5.0.0 to before 5.3.0 Fixed in 5.3.0 Patch available GHSA-2777-2vq8-c4v4
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sequelizejs:sequelize:*:*:*:*:*:node.js:*:* | 5.0.0 to before 5.3.0 | Vulnerable | Feathers-Sequalize |
- cpe:2.3:a:sequelizejs:sequelize:*:*:*:*:*:node.js:*:* Versions 5.0.0 to before 5.3.0 Vulnerable ·Feathers-Sequalize
Remediation
- Fix · GHSA-2777-2vq8-c4v4 sequelize (npm) Fixed in 5.3.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-11069
- 2026-10-03 Alias added: GHSA-2777-2vq8-c4v4
References
Advisory 3
More Feathers-Sequalize Sequelize vulnerabilities
- TI-2023-11083 SQL Injection via replacements in sequelize CVSS 3.1CRITICAL 10.0
- TI-2023-08773 Sequalize - Default support for “raw attributes” when using parentheses CVSS 3.1CRITICAL 10.0
- TI-2016-08595 SQL injection in HackerOne sequelize node module CVSS 3.0CRITICAL 9.8
- TI-2016-08591 SQL injection in HackerOne sequelize node module CVSS 3.0CRITICAL 9.8
- TI-2019-08017 SQL injection in sequelize CVSS 3.1CRITICAL 9.8
- TI-2019-08014 SQL injection in sequelize CVSS 3.1CRITICAL 9.8
Sources
- CVE-2019-11069 · CVE Program
- CVE-2019-11069 · NVD
- FIRST EPSS
- GHSA-2777-2vq8-c4v4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences