A sandbox bypass vulnerability exists in Jenkins Script Security Plugin 1.52 and earlier…
Priority MEDIUM 44Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 1 fixed, 6 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
A sandbox bypass vulnerability exists in Jenkins Script Security Plugin 1.52 and earlier in RejectASTTransformsCustomizer.java that allows attackers with Overall/Read permission to provide a Groovy script to an HTTP endpoint that can result in arbitrary code execution on the Jenkins master JVM.
Why it matters now
EPSS 0.03074 87th percentileScored 2026-11-07
Fix Partial org.jenkins-ci.plugins:script-security (Maven): 1.53Red Hat: 1 advisoryRed Hat: 1 fixed, 6 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Script Security Plugin | up to 1.52 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:script-security (Maven) | before 1.53 | 1.53 | Patch available | GHSA-jgpm-2862-q5m8 |
- Jenkins Script Security Plugin VendorJenkins Affected up to 1.52 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:script-security (Maven) Vendor— Affected before 1.53 Fixed in 1.53 Patch available GHSA-jgpm-2862-q5m8
Remediation
- Fix · GHSA-jgpm-2862-q5m8 org.jenkins-ci.plugins:script-security (Maven) Fixed in 1.53 Advisory →
Red Hat 1 advisory
- RHSA-2019:0739 Released 2019-04-10 · Red Hat rating ImportantRed Hat OpenShift Container Platform 3.11 jenkins-2-plugins security update
- Red Hat OpenShift Container Platform 3.11 jenkins-2-plugins-3.11.1552336312-1.el7
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.10 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.4 | Affected | No fix planned: Out of support scope |
| Red Hat OpenShift Container Platform 3.5 | Affected | No fix planned: Out of support scope |
| Red Hat OpenShift Container Platform 3.6 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.7 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.9 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.11 | Fixed | RHSA-2019:0739 |
Not affected: 1 product
- Red Hat OpenShift Container Platform 4
Timeline
- 2026-10-02 Threatist record created from CVE-2019-1003024
- 2026-10-03 Alias added: GHSA-jgpm-2862-q5m8
References
Advisory 3
More Jenkins Script Security vulnerabilities
- TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15845 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1HIGH 8.8
- TI-2024-22597 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1CRITICAL 9.8
- TI-2019-15850 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1HIGH 8.8
- TI-2019-15885 A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.55 and earlier allows… CVSS 3.1CRITICAL 9.8
- TI-2019-07740 Code injection in Jenkins Script Security Plugin CVSS 3.1CRITICAL 9.9
Sources
- CVE-2019-1003024 · CVE Program
- CVE-2019-1003024 · NVD
- FIRST EPSS
- GHSA-jgpm-2862-q5m8 · GitHub Advisory Database · CC BY 4.0
- CVE-2019-1003024 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences