Information disclosure in Apache Superset
Priority LOW 32CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
An information disclosure issue was found in Apache Superset 0.34.0, 0.34.1, 0.35.0, and 0.35.1. Authenticated Apache Superset users are able to retrieve other users' information, including hashed passwords, by accessing an unused and undocumented API endpoint on Apache Superset.
Why it matters now
EPSS 0.01351 71st percentileScored 2026-11-07
Fix Fixed apache-superset (PyPI): 0.35.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Superset | 0.34.0; 0.34.1; 0.35.0; 0.35.1 | — | No fix listed | CNA |
| — | apache-superset (PyPI) | 0.34.0 to before 0.35.2 | 0.35.2 | Patch available | GHSA-fxjm-wvj9-9c39 |
- Apache Superset VendorApache Affected 0.34.0; 0.34.1; 0.35.0; 0.35.1 Fixed in — No fix listed CNA
- apache-superset (PyPI) Vendor— Affected 0.34.0 to before 0.35.2 Fixed in 0.35.2 Patch available GHSA-fxjm-wvj9-9c39
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:superset:0.34.0:-:*:*:*:*:*:* | 0.34.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:superset:0.34.1:*:*:*:*:*:*:* | 0.34.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:superset:0.35.0:*:*:*:*:*:*:* | 0.35.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:superset:0.35.1:*:*:*:*:*:*:* | 0.35.1 | Vulnerable | Apache |
- cpe:2.3:a:apache:superset:0.34.0:-:*:*:*:*:*:* Versions 0.34.0 Vulnerable ·Apache
- cpe:2.3:a:apache:superset:0.34.1:*:*:*:*:*:*:* Versions 0.34.1 Vulnerable ·Apache
- cpe:2.3:a:apache:superset:0.35.0:*:*:*:*:*:*:* Versions 0.35.0 Vulnerable ·Apache
- cpe:2.3:a:apache:superset:0.35.1:*:*:*:*:*:*:* Versions 0.35.1 Vulnerable ·Apache
Remediation
- Fix · GHSA-fxjm-wvj9-9c39 apache-superset (PyPI) Fixed in 0.35.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-1932
- 2026-10-03 Alias added: GHSA-fxjm-wvj9-9c39
References
Advisory 2
More Apache Superset vulnerabilities
- TI-2023-12249 Apache Superset: Session validation vulnerability when using provided default SECRET_KEY KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05798 Deserialization of untrusted data in Superset CVSS 3.0CRITICAL 9.8
- TI-2023-21408 Apache Superset: Privilege escalation with default examples database CVSS 3.1HIGH 8.8
- TI-2023-20410 Apache Superset: Possible Unauthorized Registration of SQLite Database Connections CVSS 3.1MEDIUM 6.5
- TI-2021-09242 Apache Superset stored XSS on Dashboard markdown CVSS 3.1MEDIUM 5.4
- TI-2021-09359 Apache Superset Open Redirect CVSS 3.1MEDIUM 6.1
Sources
- CVE-2020-1932 · CVE Program
- CVE-2020-1932 · NVD
- FIRST EPSS
- GHSA-fxjm-wvj9-9c39 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences