Apache Superset: Privilege escalation with default examples database
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
Improper authorization check and possible privilege escalation on Apache Superset up to but excluding 2.1.2. Using the default examples database connection that allows access to both the examples schema and Apache Superset's metadata database, an attacker using a specially crafted CTE SQL statement could change data on the metadata database. This weakness could result on tampering with the authentication/authorization data.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Superset | before 2.1.2 | 2.1.2 | Patch available | CNA |
| — | apache-superset (PyPI) | before 2.1.2 | 2.1.2 | Patch available | GHSA-f678-j579-4xf5 |
- Apache Superset VendorApache Affected before 2.1.2 Fixed in 2.1.2 Patch available CNA
- apache-superset (PyPI) Vendor— Affected before 2.1.2 Fixed in 2.1.2 Patch available GHSA-f678-j579-4xf5
Remediation
- Fix · CNA Apache Superset (Apache Software Foundation) Fixed in 2.1.2
- Fix · GHSA-f678-j579-4xf5 apache-superset (PyPI) Fixed in 2.1.2 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apache Superset 2.1.2
3 records Highest priority Priority HIGH 1 HIGH, 2 LOW
Other records, highest priority first
- TI-2023-23406 Apache Superset: Stored XSS on API endpointPriority LOW 26
- TI-2023-22661 Apache Superset: Unnecessary read permissions within the Gamma rolePriority LOW 22
Timeline
- 2026-10-02 Threatist record created from CVE-2023-40610
- 2026-10-03 Alias added: GHSA-f678-j579-4xf5
References
Advisory 3
More Apache Superset vulnerabilities
- TI-2023-12249 Apache Superset: Session validation vulnerability when using provided default SECRET_KEY KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05798 Deserialization of untrusted data in Superset CVSS 3.0CRITICAL 9.8
- TI-2023-20410 Apache Superset: Possible Unauthorized Registration of SQLite Database Connections CVSS 3.1MEDIUM 6.5
- TI-2021-09242 Apache Superset stored XSS on Dashboard markdown CVSS 3.1MEDIUM 5.4
- TI-2021-09359 Apache Superset Open Redirect CVSS 3.1MEDIUM 6.1
- TI-2023-19373 Apache Superset: Metadata db write access can lead to remote code execution CVSS 3.1MEDIUM 6.6
Sources
- CVE-2023-40610 · CVE Program
- CVE-2023-40610 · NVD
- FIRST EPSS
- GHSA-f678-j579-4xf5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences