Read the docs
TI-2023-12249 Aliases CVE-2023-27524GHSA-5cx2-vq3h-x52c

Apache Superset: Session validation vulnerability when using provided default SECRET_KEY

Priority CRITICAL 100Exploited in the wildCWE-1188Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

Session Validation attacks in Apache Superset versions up to and including 2.0.1. Installations that have not altered the default configured SECRET_KEY according to installation instructions allow for an attacker to authenticate and access unauthorized resources. This does not affect Superset administrators who have changed the default value for SECRET_KEY config. All superset installations should always set a unique secure random SECRET_KEY. Your SECRET_KEY is used to securely sign all session cookies and encrypting sensitive information on the database. Add a strong SECRET_KEY to your `superset_config.py` file like: SECRET_KEY = <YOUR_OWN_RANDOM_GENERATED_SECRET_KEY> Alternatively you can set it with `SUPERSET_SECRET_KEY` environment variable.

Why it matters now

Exploitation Active In CISA KEV since 2024-01-08CISA due date 2024-01-29
EPSS 0.98148 99th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed apache-superset (PyPI): 2.1.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Active
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Supersetup to 2.0.1—No fix listedCNA
—apache-superset (PyPI)before 2.1.02.1.0Patch availableGHSA-5cx2-vq3h-x52c
  • Apache Superset VendorApache Affected up to 2.0.1 Fixed in — No fix listed CNA
  • apache-superset (PyPI) Vendor— Affected before 2.1.0 Fixed in 2.1.0 Patch available GHSA-5cx2-vq3h-x52c

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:superset:*:*:*:*:*:*:*:*up to 2.0.1VulnerableApache
  • cpe:2.3:a:apache:superset:*:*:*:*:*:*:*:* Versions up to 2.0.1 Vulnerable ·Apache

Remediation

  • Fix · GHSA-5cx2-vq3h-x52c apache-superset (PyPI) Fixed in 2.1.0 Advisory →

Timeline

  1. 2024-01-08 Added to CISA KEV
  2. 2026-10-02 Threatist record created from CVE-2023-27524
  3. 2026-10-03 Alias added: GHSA-5cx2-vq3h-x52c

References

  • TI-2018-05798 Deserialization of untrusted data in Superset CVSS 3.0CRITICAL 9.8
  • TI-2023-21408 Apache Superset: Privilege escalation with default examples database CVSS 3.1HIGH 8.8
  • TI-2023-20410 Apache Superset: Possible Unauthorized Registration of SQLite Database Connections CVSS 3.1MEDIUM 6.5
  • TI-2021-09242 Apache Superset stored XSS on Dashboard markdown CVSS 3.1MEDIUM 5.4
  • TI-2021-09359 Apache Superset Open Redirect CVSS 3.1MEDIUM 6.1
  • TI-2023-19373 Apache Superset: Metadata db write access can lead to remote code execution CVSS 3.1MEDIUM 6.6
See all 69 →

Sources