Read the docs

Apache

Records4054All Threatist records
Exploited (KEV)47In CISA KEV
CVSS critical776CVSS 9.0–10.0
CVSS high1543CVSS 7.0–8.9

Exploited now

Apache records in CISA KEV

Components

Products in the NVD configurations · select one to filter the records

Records

70 records in Superset · all components

Priority HIGH 74

Versions of Superset prior to 0.23 used an unsafe load method from the pickle library to deserialize data leading to possible remote code execution.

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.5341 Published 2018-11-07 Fixed in 0.23 CWE-502
Priority HIGH 66

Apache Superset up to and including 0.38.0 allowed the creation of a Markdown component on a Dashboard page for describing chart's related information.

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.86393 Published 2021-03-05 Fixed in 0.38.1 CWE-79
TI-2021-09359 CVE-2021-28125 · GHSA-pfwg-rxf4-97c3

Apache Superset Open Redirect

Priority MEDIUM 63

Apache Superset up to and including 1.0.1 allowed for the creation of an external URL that could be malicious.

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.64016 Published 2021-04-27 Fixed in 1.1.0 CWE-601
Priority MEDIUM 57

If an attacker gains write access to the Apache Superset metadata database, they could persist a specifically crafted Python object that may lead to remote code execution on Superset's web backend.

CVSS 3.1MEDIUM 6.6 Network High privileges No interaction EPSS 0.35455 Published 2023-09-06 Fixed in 2.1.1 CWE-502
Priority MEDIUM 47

Apache Superset before 1.4.2 is vulnerable to SQL injection in chart data requests.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.02901 Published 2022-04-13 Fixed in 1.4.2 CWE-89
TI-2020-10924 CVE-2020-13948 · GHSA-cj7g-h7rf-h8j9

OS command injection in Apache Superset

Priority MEDIUM 44

While investigating a bug report on Apache Superset, it was determined that an authenticated user could craft requests via a number of templated text fields in the product that would allow arbitrary access to Python’s `o…

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.03162 Published 2020-09-17 Fixed in 0.37.1 CWE-78
Priority MEDIUM 42

Apache Superset up to and including 1.3.0 when configured with ENABLE_TEMPLATE_PROCESSING on (disabled by default) allowed SQL injection when a malicious authenticated user sends an http request with a custom URL.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.01765 Published 2021-10-18 Fixed in 1.3.1 CWE-89
Priority MEDIUM 40

A where_in JINJA macro allows users to specify a quote, which combined with a carefully crafted statement would allow for SQL injection in Apache Superset.This issue affects Apache Superset: before 2.1.2, from 3.0.0 befo…

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.01188 Published 2023-12-19 Fixed in 2.1.2, 3.0.2 +1 CWE-89
TI-2021-20065 CVE-2021-44451 · GHSA-hhm3-48h2-597v

API sensitive information leak

Priority LOW 39

Apache Superset up to and including 1.3.2 allowed for registered database connections password leak for authenticated users.

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.07863 Published 2022-02-01 Fixed in 1.4.0 CWE-522
TI-2020-10928 CVE-2020-13952 · GHSA-77pw-c3j2-5fc8

Information disclosure in Apache Superset

Priority LOW 39

In the course of work on the open source project it was discovered that authenticated users running queries against Hive and Presto database engines could access information via a number of templated fields including the…

CVSS 3.1HIGH 8.1 Network Low privileges No interaction EPSS 0.02018 Published 2020-09-30 Fixed in 0.37.2 CWE-200
Priority LOW 35

An authenticated Gamma user has the ability to create a dashboard and add charts to it, this user would automatically become one of the owners of the charts allowing him to incorrectly have write permissions to these cha…

CVSS 3.1HIGH 7.7 Network Low privileges No interaction EPSS 0.0095 Published 2023-12-19 Fixed in 2.1.2, 3.0.2 +1 CWE-863
TI-2024-22992 CVE-2024-34693 · GHSA-hcr7-cqwc-q5gq

Apache Superset: Server arbitrary file read

Priority LOW 33

Improper Input Validation vulnerability in Apache Superset, allows for an authenticated attacker to create a MariaDB connection with local_infile enabled.

CVSS 3.1MEDIUM 6.8 Network High privileges No interaction EPSS 0.01584 Published 2024-06-20 Fixed in 3.1.3, 4.0.1 CWE-20
Priority LOW 33

An authenticated user with specific data permissions could access database connections stored passwords by requesting a specific REST API.

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.02067 Published 2023-04-24 Fixed in 2.1.0 CWE-522
Load more
Open these records in search →