Read the docs
TI-2020-01987 Aliases CVE-2020-2110GHSA-qvmf-36h5-3f5v

Improper input validation in Jenkins Script Security Plugin

Priority MEDIUM 41CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.

Summary

Sandbox protection in Jenkins Script Security Plugin 1.69 and earlier could be circumvented during the script compilation phase by applying AST transforming annotations to imports or by using them inside of other annotations.

Why it matters now

EPSS 0.01257 69th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:script-security (Maven): 1.70Red Hat: 3 advisories

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Script Security Pluginup to 1.69—No fix listedCNA
—org.jenkins-ci.plugins:script-security (Maven)before 1.701.70Patch availableGHSA-qvmf-36h5-3f5v
  • Jenkins Script Security Plugin VendorJenkins Affected up to 1.69 Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins:script-security (Maven) Vendor— Affected before 1.70 Fixed in 1.70 Patch available GHSA-qvmf-36h5-3f5v

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:script_security:*:*:*:*:*:jenkins:*:*up to 1.69VulnerableJenkins
  • cpe:2.3:a:jenkins:script_security:*:*:*:*:*:jenkins:*:* Versions up to 1.69 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-qvmf-36h5-3f5v org.jenkins-ci.plugins:script-security (Maven) Fixed in 1.70 Advisory →

Red Hat 3 advisories

  • RHSA-2020:3616 Released 2020-09-09 · Red Hat rating Important
    OpenShift Container Platform 4.3.35 jenkins-2-plugins security update
    • Red Hat OpenShift Container Platform 4.3 jenkins-2-plugins-4.3.1597915133-1.el7
  • RHSA-2020:2737 Released 2020-06-29 · Red Hat rating Important
    OpenShift Container Platform 4.4.z jenkins-2-plugins security update
    • Red Hat OpenShift Container Platform 4.4 jenkins-2-plugins-4.4.1592817009-1.el7
  • RHSA-2020:2478 Released 2020-06-17 · Red Hat rating Important
    OpenShift Container Platform 3.11 jenkins-2-plugins security update
    • Red Hat OpenShift Container Platform 3.11 jenkins-2-plugins-3.11.1591354111-1.el7

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenShift Container Platform 3.11Fixed RHSA-2020:2478
Red Hat OpenShift Container Platform 4.3Fixed RHSA-2020:3616
Red Hat OpenShift Container Platform 4.4Fixed RHSA-2020:2737
Red Hat OpenShift Container Platform 4.5Fixed—

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-2110
  2. 2026-10-03 Alias added: GHSA-qvmf-36h5-3f5v
  3. 2026-10-30 Fix available: Red Hat OpenShift Container Platform 4.5 · Red Hat

References

  • TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
  • TI-2019-15845 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1HIGH 8.8
  • TI-2024-22597 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1CRITICAL 9.8
  • TI-2019-15850 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1HIGH 8.8
  • TI-2019-15885 A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.55 and earlier allows… CVSS 3.1CRITICAL 9.8
  • TI-2019-07740 Code injection in Jenkins Script Security Plugin CVSS 3.1CRITICAL 9.9
See all 44 →

Sources