Improper input validation in Jenkins Pipeline: AWS Steps Plugin
Priority MEDIUM 42CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
Jenkins Pipeline: AWS Steps Plugin 1.40 and earlier does not configure its YAML parser to prevent the instantiation of arbitrary types, resulting in a remote code execution vulnerability.
Why it matters now
EPSS 0.02034 81st percentileScored 2026-11-07
Fix Fixed de.taimos:pipeline-aws (Maven): 1.41
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Pipeline: AWS Steps Plugin | up to 1.40 | — | No fix listed | CNA |
| — | de.taimos:pipeline-aws (Maven) | before 1.41 | 1.41 | Patch available | GHSA-w598-25hm-jqx3 |
- Jenkins Pipeline: AWS Steps Plugin VendorJenkins Affected up to 1.40 Fixed in — No fix listed CNA
- de.taimos:pipeline-aws (Maven) Vendor— Affected before 1.41 Fixed in 1.41 Patch available GHSA-w598-25hm-jqx3
Remediation
- Fix · GHSA-w598-25hm-jqx3 de.taimos:pipeline-aws (Maven) Fixed in 1.41 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-2166
- 2026-10-03 Alias added: GHSA-w598-25hm-jqx3
References
More Jenkins Pipeline vulnerabilities
- TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15846 A sandbox bypass vulnerability exists in Pipeline: Groovy Plugin 2.61 and earlier in… CVSS 3.1HIGH 8.8
- TI-2019-15847 A sandbox bypass vulnerability exists in Pipeline: Declarative Plugin 1.3.3 and earlier… CVSS 3.1HIGH 8.8
- TI-2023-11034 Cross-site scripting in Jenkins Pipeline: Build Step Plugin CVSS 3.1MEDIUM 5.4
- TI-2019-15886 A sandbox bypass vulnerability in Jenkins Pipeline: Groovy Plugin 2.64 and earlier allows… CVSS 3.1CRITICAL 9.8
- TI-2022-21197 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin CVSS 3.1CRITICAL 9.9
Sources
- CVE-2020-2166 · CVE Program
- CVE-2020-2166 · NVD
- FIRST EPSS
- GHSA-w598-25hm-jqx3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences