improper access control vulnerability in Helpdesk
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-284.
Summary
The vulnerability have been reported to affect earlier versions of QTS. If exploited, this improper access control vulnerability could allow attackers to compromise the security of the software by gaining privileges, or reading sensitive information. This issue affects: QNAP Systems Inc. Helpdesk versions prior to 3.0.3.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Active
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Helpdesk (QNAP Systems Inc.) Fixed in 3.0.3
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
QNAP Systems Helpdesk 3.0.3
2 records Highest priority Priority CRITICAL 1 CRITICAL, 1 MEDIUM
Other records, highest priority first
- TI-2020-02219 command injection vulnerability in HelpdeskPriority MEDIUM 48
Timeline
- 2022-03-25 Added to CISA KEV
- 2026-10-02 Threatist record created from CVE-2020-2506
- 2026-10-03 Alias added: GHSA-vph4-5mf4-28v5
References
More QNAP Helpdesk vulnerabilities
- TI-2020-02219 command injection vulnerability in Helpdesk CVSS 3.1CRITICAL 9.8
- TI-2018-00668 Command injection in QNAP Helpdesk in QTS CVSS 3.0CRITICAL 9.8
- TI-2020-02212 Improper access control in QNAP Helpdesk CVSS 3.1CRITICAL 9.8
- TI-2021-09805 Improper Access Control Vulnerability in Helpdesk CVSS 3.1HIGH 8.8
- TI-2024-33827 Improper certificate validation in QNAP Helpdesk CVSS 4.0HIGH 7.7
- TI-2018-00677 Improper privilege management in QNAP NAS devices CVSS 3.1HIGH 7.5
Sources
- CVE-2020-2506 · CVE Program
- CVE-2020-2506 · NVD
- CISA Known Exploited Vulnerabilities
- FIRST EPSS
- GHSA-vph4-5mf4-28v5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences