Cross-site scripting (XSS) in phpoffice/phpspreadsheet
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
This affects the package phpoffice/phpspreadsheet from 0.0.0. The library is vulnerable to XSS when creating an html output from an excel file by adding a comment on any cell. The root cause of this issue is within the HTML writer where user comments are concatenated as part of link and this is returned as HTML. A fix for this issue is available on commit 0ed5b800be2136bcb8fa9c1bdf59abc957a98845/master branch.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | phpoffice/phpspreadsheet | 0.0.0 and later | — | No fix listed | CNA |
| — | phpoffice/phpspreadsheet (Packagist) | before 1.16.0 | 1.16.0 | Patch available | GHSA-4mqv-gcr3-pff9 |
| — | phpoffice/phpexcel (Packagist) | up to 1.8.2 | — | No fix listed | GHSA-4mqv-gcr3-pff9 |
- phpoffice/phpspreadsheet Vendor— Affected 0.0.0 and later Fixed in — No fix listed CNA
- phpoffice/phpspreadsheet (Packagist) Vendor— Affected before 1.16.0 Fixed in 1.16.0 Patch available GHSA-4mqv-gcr3-pff9
- phpoffice/phpexcel (Packagist) Vendor— Affected up to 1.8.2 Fixed in — No fix listed GHSA-4mqv-gcr3-pff9
Remediation
- Fix · GHSA-4mqv-gcr3-pff9 phpoffice/phpspreadsheet (Packagist) Fixed in 1.16.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-7776
- 2026-10-03 Alias added: GHSA-4mqv-gcr3-pff9
References
More PHPOffice Phpspreadsheet vulnerabilities
- TI-2026-26406 PhpSpreadsheet SSRF and RCE via PHP stream wrappers in IOFactory::load CVSS 4.0CRITICAL 9.2
- TI-2024-37339 PhpSpreadsheet vulnerable to unauthorized reflected XSS in Currency.php file CVSS 4.0HIGH 8.3
- TI-2024-37338 PhpSpreadsheet allows unauthorized reflected XSS in `Convert-Online.php` file CVSS 4.0HIGH 8.3
- TI-2024-37325 PhpSpreadsheet vulnerable to unauthorized reflected XSS in the Accounting.php file CVSS 4.0HIGH 8.3
- TI-2024-37324 PhpSpreadsheet vulnerable to unauthorized reflected XSS in the constructor of the Downloader class CVSS 4.0HIGH 8.3
- TI-2024-30160 XML External Entity Reference (XXE) in PHPSpreadsheet CVSS 3.1HIGH 8.8
Sources
- CVE-2020-7776 · CVE Program
- CVE-2020-7776 · NVD
- FIRST EPSS
- GHSA-4mqv-gcr3-pff9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences