Read the docs
TI-2020-11203 Aliases CVE-2020-14332GHSA-j667-c2hm-f2wp

Sensitive information in log files in Red Hat Ansible

Priority LOW 25CWE-117Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Partial Red Hat: 2 fixed, 2 without a fix

Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-532.

Summary

A flaw was found in the Ansible Engine when using module_args. Tasks executed with check mode (--check-mode) do not properly neutralize sensitive data exposed in the event data. This flaw allows unauthorized users to read this data. The highest threat from this vulnerability is to confidentiality.

Why it matters now

EPSS 0.00407 35th percentileScored 2026-11-07
Fix Partial ansible (PyPI): 2.8.14, 2.9.12, 2.10.1rc2Red Hat: 1 advisoryRed Hat: 2 fixed, 2 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Red HatAnsible2.9.12; 2.8.14—No fix listedCNA
—ansible (PyPI)before 2.8.142.8.14Patch availableGHSA-j667-c2hm-f2wp
—ansible (PyPI)2.9.0a1 to before 2.9.122.9.12Patch availableGHSA-j667-c2hm-f2wp
—ansible (PyPI)2.10.0a1 to before 2.10.1rc22.10.1rc2Patch availableGHSA-j667-c2hm-f2wp
  • Ansible VendorRed Hat Affected 2.9.12; 2.8.14 Fixed in — No fix listed CNA
  • ansible (PyPI) Vendor— Affected before 2.8.14 Fixed in 2.8.14 Patch available GHSA-j667-c2hm-f2wp
  • ansible (PyPI) Vendor— Affected 2.9.0a1 to before 2.9.12 Fixed in 2.9.12 Patch available GHSA-j667-c2hm-f2wp
  • ansible (PyPI) Vendor— Affected 2.10.0a1 to before 2.10.1rc2 Fixed in 2.10.1rc2 Patch available GHSA-j667-c2hm-f2wp

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:redhat:ansible_engine:*:*:*:*:*:*:*:*2.8.0 to before 2.8.14; 2.9.0 to before 2.9.12VulnerableRed Hat
cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*10.0VulnerableDebian
  • cpe:2.3:a:redhat:ansible_engine:*:*:*:*:*:*:*:* Versions 2.8.0 to before 2.8.14; 2.9.0 to before 2.9.12 Vulnerable ·Red Hat
  • cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian

Remediation

  • Fix · GHSA-j667-c2hm-f2wp ansible (PyPI) Fixed in 2.8.14 Advisory →
  • Fix · GHSA-j667-c2hm-f2wp ansible (PyPI) Fixed in 2.9.12 Advisory →
  • Fix · GHSA-j667-c2hm-f2wp ansible (PyPI) Fixed in 2.10.1rc2 Advisory →

Red Hat 1 advisory

  • RHSA-2020:3600 Released 2020-09-01 · Red Hat rating Important
    Ansible security and bug fix update (2.8.15)
    • Red Hat Ansible Engine 2.8 for RHEL 7 Server ansible-2.8.15-1.el7ae
    • Red Hat Ansible Engine 2.8 for RHEL 8 ansible-2.8.15-1.el8ae

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Ansible Tower 3AffectedNo fix planned: Out of support scope
Red Hat OpenStack Platform 10 (Newton)AffectedNo fix planned: Out of support scope
Red Hat Ansible Engine 2.8 for RHEL 7 ServerFixed RHSA-2020:3600
Red Hat Ansible Engine 2.8 for RHEL 8Fixed RHSA-2020:3600
Not affected: 4 products
  • Red Hat Ceph Storage 2
  • Red Hat Ceph Storage 3
  • Red Hat OpenStack Platform 13 (Queens)
  • Red Hat Storage 3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-14332
  2. 2026-10-03 Alias added: GHSA-j667-c2hm-f2wp

References

  • TI-2018-05593 transport.py in the SSH server implementation of Paramiko before 1.17.6, 1.18.x before… CVSS 3.1CRITICAL 9.8
  • TI-2017-05127 Improper input validation in [UNKNOWN] ansible CVSS 3.1CRITICAL 9.8
  • TI-2021-03523 Information disclosure in ansible CVSS 3.1HIGH 7.5
  • TI-2019-11051 Sensitive information in log files in Red Hat Ansible CVSS 3.1HIGH 7.8
  • TI-2018-07689 Untrusted search path in [UNKNOWN] ansible CVSS 3.1HIGH 7.8
  • TI-2018-07688 Untrusted search path in [UNKNOWN] ansible CVSS 3.0HIGH 7.8
See all 24 →

Sources