Improper authorization in Gallagher Command Centre
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-285.
Summary
In Gallagher Command Centre versions 8.10 prior to 8.10.1134(MR4), 8.00 prior to 8.00.1161(MR5), 7.90 prior to 7.90.991(MR5), 7.80 prior to 7.80.960(MR2), 7.70 and earlier, any operator account has access to all data that would be replicated if the system were to be (or is) attached to a multi-server environment. This can include plain text credentials for DVR systems and card details used for physical access/alarm/perimeter components.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Gallagher | Command Centre | up to 7.70; 8.10 to before 8.10.1134(MR4); 8.00 to before 8.00.1161(MR5); 7.90 to before 7.90.991(MR5); 7.80 to before 7.80.960(MR2) | 8.10.1134(MR4), 8.00.1161(MR5), 7.90.991(MR5), 7.80.960(MR2) | Patch available | CNA |
- Command Centre VendorGallagher Affected up to 7.70; 8.10 to before 8.10.1134(MR4); 8.00 to before 8.00.1161(MR5); 7.90 to before 7.90.991(MR5); 7.80 to before 7.80.960(MR2) Fixed in 8.10.1134(MR4), 8.00.1161(MR5), 7.90.991(MR5), 7.80.960(MR2) Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gallagher:command_centre:*:*:*:*:*:*:*:* | 7.80 to before 7.80.960; 7.90 to before 7.90.991; 8.00 to before 8.00.1161; 8.10 to before 8.10.1134 | Vulnerable | Gallagher |
| cpe:2.3:a:gallagher:command_centre:7.80.960:-:*:*:*:*:*:* | 7.80.960 | Vulnerable | Gallagher |
| cpe:2.3:a:gallagher:command_centre:7.90.991:-:*:*:*:*:*:* | 7.90.991 | Vulnerable | Gallagher |
| cpe:2.3:a:gallagher:command_centre:8.00.1161:-:*:*:*:*:*:* | 8.00.1161 | Vulnerable | Gallagher |
| cpe:2.3:a:gallagher:command_centre:8.10.1134:-:*:*:*:*:*:* | 8.10.1134 | Vulnerable | Gallagher |
- cpe:2.3:a:gallagher:command_centre:*:*:*:*:*:*:*:* Versions 7.80 to before 7.80.960; 7.90 to before 7.90.991; 8.00 to before 8.00.1161; 8.10 to before 8.10.1134 Vulnerable ·Gallagher
- cpe:2.3:a:gallagher:command_centre:7.80.960:-:*:*:*:*:*:* Versions 7.80.960 Vulnerable ·Gallagher
- cpe:2.3:a:gallagher:command_centre:7.90.991:-:*:*:*:*:*:* Versions 7.90.991 Vulnerable ·Gallagher
- cpe:2.3:a:gallagher:command_centre:8.00.1161:-:*:*:*:*:*:* Versions 8.00.1161 Vulnerable ·Gallagher
- cpe:2.3:a:gallagher:command_centre:8.10.1134:-:*:*:*:*:*:* Versions 8.10.1134 Vulnerable ·Gallagher
Remediation
- Fix · CNA Command Centre (Gallagher) Fixed in 8.10.1134(MR4), 8.00.1161(MR5), 7.90.991(MR5), 7.80.960(MR2)
Timeline
- 2026-10-02 Threatist record created from CVE-2020-16096
- 2026-10-03 Alias added: GHSA-95hf-gv4r-6jjr
References
More Gallagher Command Centre vulnerabilities
- TI-2021-05931 Improper authorization in Gallagher Command Centre CVSS 3.1CRITICAL 9.9
- TI-2020-12668 Improper authentication in Gallagher Command Centre CVSS 3.1CRITICAL 9.8
- TI-2019-11404 An issue was discovered in Gallagher Command Centre 8.10 before 8.10.1092(MR2). CVSS 3.0CRITICAL 9.8
- TI-2021-05986 SQL injection in Gallagher Command Centre CVSS 3.1CRITICAL 9.9
- TI-2020-12673 Incorrect type conversion in Gallagher Command Centre CVSS 3.1HIGH 8.8
- TI-2024-14493 Insufficiently protected credentials in Gallagher Command Centre Server CVSS 3.1CRITICAL 9.1
Sources
- CVE-2020-16096 · CVE Program
- CVE-2020-16096 · NVD
- FIRST EPSS
- GHSA-95hf-gv4r-6jjr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences