Incorrect type conversion in Gallagher Command Centre
Priority MEDIUM 42CWE-704Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-704 and the CVSS impact.
Summary
Type confusion in Gallagher Command Centre Server allows a remote attacker to crash the server or possibly cause remote code execution. This issue affects: Gallagher Command Centre 8.30 versions prior to 8.30.1236(MR1); 8.20 versions prior to 8.20.1166(MR3); 8.10 versions prior to 8.10.1211(MR5); version 8.00 and prior versions.
Why it matters now
EPSS 0.02292 83rd percentileScored 2026-11-07
Fix Fixed Command Centre (Gallagher): 8.30.1236(MR1), 8.20.1166(MR3), 8.10.1211(MR5)
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Gallagher | Command Centre | up to 8.00; 8.30 to before 8.30.1236(MR1); 8.20 to before 8.20.1166(MR3); 8.10 to before 8.10.1211(MR5) | 8.30.1236(MR1), 8.20.1166(MR3), 8.10.1211(MR5) | Patch available | CNA |
- Command Centre VendorGallagher Affected up to 8.00; 8.30 to before 8.30.1236(MR1); 8.20 to before 8.20.1166(MR3); 8.10 to before 8.10.1211(MR5) Fixed in 8.30.1236(MR1), 8.20.1166(MR3), 8.10.1211(MR5) Patch available CNA
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gallagher:command_centre:*:*:*:*:*:*:*:* | up to 8.00; 8.10 to before 8.10.1211; 8.20 to before 8.20.1166; 8.30 to before 8.30.1236 | Vulnerable | Gallagher |
| cpe:2.3:a:gallagher:command_centre:8.10.1211:-:*:*:*:*:*:* | 8.10.1211 | Vulnerable | Gallagher |
| cpe:2.3:a:gallagher:command_centre:8.10.1211:maintenance_release5:*:*:*:*:*:* | 8.10.1211 maintenance_release5 | Vulnerable | Gallagher |
| cpe:2.3:a:gallagher:command_centre:8.20.1166:-:*:*:*:*:*:* | 8.20.1166 | Vulnerable | Gallagher |
| cpe:2.3:a:gallagher:command_centre:8.20.1166:maintenance_release3:*:*:*:*:*:* | 8.20.1166 maintenance_release3 | Vulnerable | Gallagher |
| cpe:2.3:a:gallagher:command_centre:8.30.1236:-:*:*:*:*:*:* | 8.30.1236 | Vulnerable | Gallagher |
| cpe:2.3:a:gallagher:command_centre:8.30.1236:maintenance_release1:*:*:*:*:*:* | 8.30.1236 maintenance_release1 | Vulnerable | Gallagher |
- cpe:2.3:a:gallagher:command_centre:*:*:*:*:*:*:*:* Versions up to 8.00; 8.10 to before 8.10.1211; 8.20 to before 8.20.1166; 8.30 to before 8.30.1236 Vulnerable ·Gallagher
- cpe:2.3:a:gallagher:command_centre:8.10.1211:-:*:*:*:*:*:* Versions 8.10.1211 Vulnerable ·Gallagher
- cpe:2.3:a:gallagher:command_centre:8.10.1211:maintenance_release5:*:*:*:*:*:* Versions 8.10.1211 maintenance_release5 Vulnerable ·Gallagher
- cpe:2.3:a:gallagher:command_centre:8.20.1166:-:*:*:*:*:*:* Versions 8.20.1166 Vulnerable ·Gallagher
- cpe:2.3:a:gallagher:command_centre:8.20.1166:maintenance_release3:*:*:*:*:*:* Versions 8.20.1166 maintenance_release3 Vulnerable ·Gallagher
- cpe:2.3:a:gallagher:command_centre:8.30.1236:-:*:*:*:*:*:* Versions 8.30.1236 Vulnerable ·Gallagher
- cpe:2.3:a:gallagher:command_centre:8.30.1236:maintenance_release1:*:*:*:*:*:* Versions 8.30.1236 maintenance_release1 Vulnerable ·Gallagher
Remediation
- Fix · CNA Command Centre (Gallagher) Fixed in 8.30.1236(MR1), 8.20.1166(MR3), 8.10.1211(MR5)
Timeline
- 2026-10-02 Threatist record created from CVE-2020-16103
- 2026-10-03 Alias added: GHSA-6v85-364q-mgv8
References
More Gallagher Command Centre vulnerabilities
- TI-2021-05931 Improper authorization in Gallagher Command Centre CVSS 3.1CRITICAL 9.9
- TI-2020-12668 Improper authentication in Gallagher Command Centre CVSS 3.1CRITICAL 9.8
- TI-2020-12666 Improper authorization in Gallagher Command Centre CVSS 3.1CRITICAL 9.9
- TI-2019-11404 An issue was discovered in Gallagher Command Centre 8.10 before 8.10.1092(MR2). CVSS 3.0CRITICAL 9.8
- TI-2021-05986 SQL injection in Gallagher Command Centre CVSS 3.1CRITICAL 9.9
- TI-2024-14493 Insufficiently protected credentials in Gallagher Command Centre Server CVSS 3.1CRITICAL 9.1
Sources
- CVE-2020-16103 · CVE Program
- CVE-2020-16103 · NVD
- FIRST EPSS
- GHSA-6v85-364q-mgv8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences