Improper authentication in Gallagher Command Centre
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-287.
Summary
It is possible to enumerate access card credentials via an unauthenticated network connection to the server in versions of Command Centre v8.20 prior to v8.20.1166(MR3), versions of 8.10 prior to v8.10.1211(MR5), versions of 8.00 prior to v8.00.1228(MR6), all versions of 7.90 and earlier. These credentials can then be used to encode low security cards to be used by the system where insecure card technologies are supported.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Gallagher | Command Centre | up to 7.90; 8.20 to before 8.20.1166(MR3); 8.10 to before 8.10.1211(MR5); 8.00 to before 8.00.1228(MR6) | 8.20.1166(MR3), 8.10.1211(MR5), 8.00.1228(MR6) | Patch available | CNA |
- Command Centre VendorGallagher Affected up to 7.90; 8.20 to before 8.20.1166(MR3); 8.10 to before 8.10.1211(MR5); 8.00 to before 8.00.1228(MR6) Fixed in 8.20.1166(MR3), 8.10.1211(MR5), 8.00.1228(MR6) Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gallagher:command_centre:*:*:*:*:*:*:*:* | 8.00 to before 8.00.1228; 8.10 to before 8.10.1211; 8.20 to before 8.20.1166; 8.30 to before 8.30.1236 | Vulnerable | Gallagher |
| cpe:2.3:a:gallagher:command_centre:8.00.1228:-:*:*:*:*:*:* | 8.00.1228 | Vulnerable | Gallagher |
| cpe:2.3:a:gallagher:command_centre:8.10.1211:-:*:*:*:*:*:* | 8.10.1211 | Vulnerable | Gallagher |
| cpe:2.3:a:gallagher:command_centre:8.20.1166:-:*:*:*:*:*:* | 8.20.1166 | Vulnerable | Gallagher |
| cpe:2.3:a:gallagher:command_centre:8.30.1236:-:*:*:*:*:*:* | 8.30.1236 | Vulnerable | Gallagher |
- cpe:2.3:a:gallagher:command_centre:*:*:*:*:*:*:*:* Versions 8.00 to before 8.00.1228; 8.10 to before 8.10.1211; 8.20 to before 8.20.1166; 8.30 to before 8.30.1236 Vulnerable ·Gallagher
- cpe:2.3:a:gallagher:command_centre:8.00.1228:-:*:*:*:*:*:* Versions 8.00.1228 Vulnerable ·Gallagher
- cpe:2.3:a:gallagher:command_centre:8.10.1211:-:*:*:*:*:*:* Versions 8.10.1211 Vulnerable ·Gallagher
- cpe:2.3:a:gallagher:command_centre:8.20.1166:-:*:*:*:*:*:* Versions 8.20.1166 Vulnerable ·Gallagher
- cpe:2.3:a:gallagher:command_centre:8.30.1236:-:*:*:*:*:*:* Versions 8.30.1236 Vulnerable ·Gallagher
Remediation
- Fix · CNA Command Centre (Gallagher) Fixed in 8.20.1166(MR3), 8.10.1211(MR5), 8.00.1228(MR6)
Timeline
- 2026-10-02 Threatist record created from CVE-2020-16098
- 2026-10-03 Alias added: GHSA-r88h-whf8-g952
References
More Gallagher Command Centre vulnerabilities
- TI-2021-05931 Improper authorization in Gallagher Command Centre CVSS 3.1CRITICAL 9.9
- TI-2020-12666 Improper authorization in Gallagher Command Centre CVSS 3.1CRITICAL 9.9
- TI-2019-11404 An issue was discovered in Gallagher Command Centre 8.10 before 8.10.1092(MR2). CVSS 3.0CRITICAL 9.8
- TI-2021-05986 SQL injection in Gallagher Command Centre CVSS 3.1CRITICAL 9.9
- TI-2020-12673 Incorrect type conversion in Gallagher Command Centre CVSS 3.1HIGH 8.8
- TI-2024-14493 Insufficiently protected credentials in Gallagher Command Centre Server CVSS 3.1CRITICAL 9.1
Sources
- CVE-2020-16098 · CVE Program
- CVE-2020-16098 · NVD
- FIRST EPSS
- GHSA-r88h-whf8-g952 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences