SQL injection in Gallagher Command Centre
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-89.
Summary
A SQL Injection vulnerability in the OPCUA interface of Gallagher Command Centre allows a remote unprivileged Command Centre Operator to modify Command Centre databases undetected. This issue affects: Gallagher Command Centre 8.40 versions prior to 8.40.1888 (MR3); 8.30 versions prior to 8.30.1359 (MR3); 8.20 versions prior to 8.20.1259 (MR5); 8.10 versions prior to 8.10.1284 (MR7); version 8.00 and prior versions.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Gallagher | Command Centre | up to 8.00; 8.40 to before 8.40.1888 (MR3); 8.30 to before 8.30.1359 (MR3); 8.20 to before 8.20.1259 (MR5); 8.10 to before 8.10.1284 (MR7) | 8.40.1888 (MR3), 8.30.1359 (MR3), 8.20.1259 (MR5), 8.10.1284 (MR7) | Patch available | CNA |
- Command Centre VendorGallagher Affected up to 8.00; 8.40 to before 8.40.1888 (MR3); 8.30 to before 8.30.1359 (MR3); 8.20 to before 8.20.1259 (MR5); 8.10 to before 8.10.1284 (MR7) Fixed in 8.40.1888 (MR3), 8.30.1359 (MR3), 8.20.1259 (MR5), 8.10.1284 (MR7) Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gallagher:command_centre:*:*:*:*:*:*:*:* | up to 8.00; 8.10 to before 8.10.1284; 8.20 to before 8.20.1259; 8.30 to before 8.30.1359; 8.40 to before 8.40.1888 | Vulnerable | Gallagher |
| cpe:2.3:a:gallagher:command_centre:8.10.1284:-:*:*:*:*:*:* | 8.10.1284 | Vulnerable | Gallagher |
| cpe:2.3:a:gallagher:command_centre:8.20.1259:-:*:*:*:*:*:* | 8.20.1259 | Vulnerable | Gallagher |
| cpe:2.3:a:gallagher:command_centre:8.30.1359:-:*:*:*:*:*:* | 8.30.1359 | Vulnerable | Gallagher |
| cpe:2.3:a:gallagher:command_centre:8.40.1888:-:*:*:*:*:*:* | 8.40.1888 | Vulnerable | Gallagher |
- cpe:2.3:a:gallagher:command_centre:*:*:*:*:*:*:*:* Versions up to 8.00; 8.10 to before 8.10.1284; 8.20 to before 8.20.1259; 8.30 to before 8.30.1359; 8.40 to before 8.40.1888 Vulnerable ·Gallagher
- cpe:2.3:a:gallagher:command_centre:8.10.1284:-:*:*:*:*:*:* Versions 8.10.1284 Vulnerable ·Gallagher
- cpe:2.3:a:gallagher:command_centre:8.20.1259:-:*:*:*:*:*:* Versions 8.20.1259 Vulnerable ·Gallagher
- cpe:2.3:a:gallagher:command_centre:8.30.1359:-:*:*:*:*:*:* Versions 8.30.1359 Vulnerable ·Gallagher
- cpe:2.3:a:gallagher:command_centre:8.40.1888:-:*:*:*:*:*:* Versions 8.40.1888 Vulnerable ·Gallagher
Remediation
- Fix · CNA Command Centre (Gallagher) Fixed in 8.40.1888 (MR3), 8.30.1359 (MR3), 8.20.1259 (MR5), 8.10.1284 (MR7)
Timeline
- 2026-10-02 Threatist record created from CVE-2021-23230
- 2026-10-03 Alias added: GHSA-3xrp-cm65-f8f5
- 2026-10-07 EPSS moved to the 50th–90th percentile
References
More Gallagher Command Centre vulnerabilities
- TI-2021-05931 Improper authorization in Gallagher Command Centre CVSS 3.1CRITICAL 9.9
- TI-2020-12668 Improper authentication in Gallagher Command Centre CVSS 3.1CRITICAL 9.8
- TI-2020-12666 Improper authorization in Gallagher Command Centre CVSS 3.1CRITICAL 9.9
- TI-2019-11404 An issue was discovered in Gallagher Command Centre 8.10 before 8.10.1092(MR2). CVSS 3.0CRITICAL 9.8
- TI-2020-12673 Incorrect type conversion in Gallagher Command Centre CVSS 3.1HIGH 8.8
- TI-2024-14493 Insufficiently protected credentials in Gallagher Command Centre Server CVSS 3.1CRITICAL 9.1
Sources
- CVE-2021-23230 · CVE Program
- CVE-2021-23230 · NVD
- FIRST EPSS
- GHSA-3xrp-cm65-f8f5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences