Read the docs
TI-2020-20050 Aliases CVE-2020-37289

Improper input validation in Vyper lets interface return values overflow uint8

Priority LOW 28CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
—
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA.

Summary

Vyper before 0.3.1 has no uint8 type, so interface return values declared as uint8, such as ERC20.decimals(), are stored in uint256 variables without bounds checking. A malicious contract can return values greater than 255 to manipulate or bypass contract logic that relies on these values. An unauthenticated remote attacker can exploit this by deploying or controlling a contract that the victim contract calls, which can affect integrity.

Written with Claude Haiku 5.5 from the sources below · 2026-11-02

Description from the CNA

Vyper before 0.3.1 lacks a uint8 type, allowing interface return values declared as uint8, such as ERC20.decimals(), to be stored in uint256 variables without bounds checking. Malicious contracts can return values greater than 255 to manipulate or bypass contract logic that relies on these values.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00261 18th percentileScored 2026-11-07
Fix Fixed vyper (vyperlang): 0.3.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
vyperlangvyperbefore 0.3.10.3.1Patch availableCNA
  • vyper Vendorvyperlang Affected before 0.3.1 Fixed in 0.3.1 Patch available CNA

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:vyperlang:vyper:*:*:*:*:*:*:*:*——vyperlang
  • cpe:2.3:a:vyperlang:vyper:*:*:*:*:*:*:*:* Versions — — ·vyperlang

Remediation

Vyper users should upgrade to version 0.3.1, which fixes this flaw. The sources list no fixed version for Red Hat products beyond marking one product as not affected.

Written with Claude Haiku 5.5 from the sources below · 2026-11-02

  • Fix · CNA vyper (vyperlang) Fixed in 0.3.1

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-21 Threatist record created from CVE-2020-37289
  2. 2026-10-22 Priority changed: MEDIUM → LOW
  3. 2026-10-28 CISA SSVC decision points changed
  4. 2026-11-02 Affected versions changed · Red Hat
  5. 2026-11-02 CVSS score added · Red Hat

References

  • TI-2024-16182 Vyper bounds check on built-in `slice()` function can be overflowed CVSS 3.1CRITICAL 9.8
  • TI-2024-14992 concat built-in can corrupt memory in vyper CVSS 3.1CRITICAL 9.8
  • TI-2024-16184 Vyper array negative index vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2022-08657 Integer bounds error in Vyper CVSS 3.1CRITICAL 9.8
  • TI-2022-11796 Multiple evaluation of contract address in call in vyper CVSS 3.1HIGH 8.2
  • TI-2026-78730 Optimizer miscompilation of msg.value | K in Vyper ternary branches CVSS 4.0HIGH 8.2
See all 52 →

Sources