Read the docs
TI-2021-03249 Aliases CVE-2021-4392GHSA-4jpr-x549-v9v3

eCommerce Product Catalog Plugin for WordPress <= 2.9.43 - Cross-Site Request Forgery Bypass

Priority LOW 21CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-352.

Summary

The eCommerce Product Catalog Plugin for WordPress plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.9.43. This is due to missing or incorrect nonce validation on the implecode_save_products_meta() function. This makes it possible for unauthenticated attackers to save product meta data via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00476 41st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed eCommerce Product Catalog Plugin for WordPress (implecode): 2.9.44

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
impleCodeeCommerce Product Catalog Plugin for WordPressbefore 2.9.442.9.44Patch availableCNA
  • eCommerce Product Catalog Plugin for WordPress VendorimpleCode Affected before 2.9.44 Fixed in 2.9.44 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:implecode:ecommerce_product_catalog:*:*:*:*:*:wordpress:*:*up to 2.9.43VulnerableimpleCode
  • cpe:2.3:a:implecode:ecommerce_product_catalog:*:*:*:*:*:wordpress:*:* Versions up to 2.9.43 Vulnerable ·impleCode

Remediation

  • Fix · CNA eCommerce Product Catalog Plugin for WordPress (implecode) Fixed in 2.9.44

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-4392
  2. 2026-10-03 Alias added: GHSA-4jpr-x549-v9v3

References

  • TI-2023-28334 WordPress eCommerce Product Catalog Plugin <= 3.3.26 is vulnerable to Sensitive Data Exposure CVSS 3.1HIGH 7.5
  • TI-2021-07157 eCommerce Product Catalog for WordPress < 3.0.39 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
  • TI-2023-25947 WordPress eCommerce Product Catalog Plugin <= 3.3.26 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
  • TI-2023-05509 eCommerce Product Catalog Plugin for WordPress < 3.3.26 - Products Deletion via CSRF CVSS 3.1MEDIUM 6.5
  • TI-2023-10522 WordPress eCommerce Product Catalog Plugin <= 3.3.4 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
  • TI-2023-01389 eCommerce Product Catalog plugin for WordPress <= 3.3.8 - Authenticated (Administrator+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8
See all 7 →

Sources