WP Prayer <= 1.6.5 - Cross-Site Request Forgery Bypass
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-352.
Summary
The WP Prayer plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.6.5. This is due to missing or incorrect nonce validation on the save() and export() functions. This makes it possible for unauthenticated attackers to save plugin settings and trigger a data export via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| abrg | WP Prayer | up to 1.6.5 | — | No fix listed | CNA |
- WP Prayer Vendorabrg Affected up to 1.6.5 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2021-4412
- 2026-10-03 Alias added: GHSA-45fv-hg56-qgcj
References
Advisory 8
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a7efbdb1-989f-4171-ab55-aff66014337a?source=cve
- https://blog.nintechnet.com/25-wordpress-plugins-vulnerable-to-csrf-attacks/
- https://blog.nintechnet.com/more-wordpress-plugins-and-themes-vulnerable-to-csrf-attacks/
- https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-3/
- https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-2/
- https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-1/
- https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-5/
- https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-4/
More Go Prayer Wp Prayer vulnerabilities
- TI-2024-03177 WP Prayer <= 2.0.9 - Email Settings Update via CSRF CVSS 3.1HIGH 8.8
- TI-2024-03178 WP Prayer <= 2.0.9 - Arbitrary Prayer Deletion via CSRF CVSS 3.1MEDIUM 5.3
- TI-2024-03176 WP Prayer <= 2.0.9 - Settings Update via CSRF CVSS 3.1HIGH 7.6
- TI-2023-10981 WordPress WP Prayer Plugin <= 1.9.6 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
- TI-2021-06605 WP Prayer < 1.6.2 - Authenticated Stored Cross-Site Scripting (XSS) CVSS 3.1MEDIUM 5.4
Sources
- CVE-2021-4412 · CVE Program
- CVE-2021-4412 · NVD
- FIRST EPSS
- GHSA-45fv-hg56-qgcj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences