Read the docs
TI-2021-06605 Aliases CVE-2021-24313GHSA-77vm-hfph-f8g6

WP Prayer < 1.6.2 - Authenticated Stored Cross-Site Scripting (XSS)

Priority LOW 26CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The WP Prayer WordPress plugin before 1.6.2 provides the functionality to store requested prayers/praises and list them on a WordPress website. These stored prayer/praise requests can be listed by using the WP Prayer engine. An authenticated WordPress user with any role can fill in the form to request a prayer. The form to request prayers or praises have several fields. The 'prayer request' and 'praise request' fields do not use proper input validation and can be used to store XSS payloads.

Why it matters now

EPSS 0.00698 53rd percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed WP Prayer (Unknown): 1.6.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownWP Prayer1.6.2 to before 1.6.21.6.2Patch availableCNA
  • WP Prayer VendorUnknown Affected 1.6.2 to before 1.6.2 Fixed in 1.6.2 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:goprayer:wp_prayer:*:*:*:*:*:wordpress:*:*before 1.6.2VulnerableGo Prayer
  • cpe:2.3:a:goprayer:wp_prayer:*:*:*:*:*:wordpress:*:* Versions before 1.6.2 Vulnerable ·Go Prayer

Remediation

  • Fix · CNA WP Prayer (Unknown) Fixed in 1.6.2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24313
  2. 2026-10-03 Alias added: GHSA-77vm-hfph-f8g6

References

  • TI-2024-03177 WP Prayer <= 2.0.9 - Email Settings Update via CSRF CVSS 3.1HIGH 8.8
  • TI-2024-03178 WP Prayer <= 2.0.9 - Arbitrary Prayer Deletion via CSRF CVSS 3.1MEDIUM 5.3
  • TI-2024-03176 WP Prayer <= 2.0.9 - Settings Update via CSRF CVSS 3.1HIGH 7.6
  • TI-2023-10981 WordPress WP Prayer Plugin <= 1.9.6 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
  • TI-2021-03269 WP Prayer <= 1.6.5 - Cross-Site Request Forgery Bypass CVSS 3.1MEDIUM 4.3

Sources