Read the docs
TI-2024-03176 Aliases CVE-2024-3405GHSA-rm3h-m7rx-3jrq

WP Prayer <= 2.0.9 - Settings Update via CSRF

Priority LOW 33CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
Low · High · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-352.

Summary

The WP Prayer WordPress plugin through 2.0.9 does not have CSRF check in place when updating its settings, which could allow attackers to make a logged in admin change them via a CSRF attack

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00258 17th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownWP Prayerup to 2.0.9—No fix listedCNA
  • WP Prayer VendorUnknown Affected up to 2.0.9 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:goprayer:wp_prayer:*:*:*:*:*:wordpress:*:*up to 2.0.9VulnerableGo Prayer
  • cpe:2.3:a:goprayer:wp_prayer:*:*:*:*:*:wordpress:*:* Versions up to 2.0.9 Vulnerable ·Go Prayer

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-3405
  2. 2026-10-03 Alias added: GHSA-rm3h-m7rx-3jrq

References

  • TI-2024-03177 WP Prayer <= 2.0.9 - Email Settings Update via CSRF CVSS 3.1HIGH 8.8
  • TI-2024-03178 WP Prayer <= 2.0.9 - Arbitrary Prayer Deletion via CSRF CVSS 3.1MEDIUM 5.3
  • TI-2023-10981 WordPress WP Prayer Plugin <= 1.9.6 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
  • TI-2021-06605 WP Prayer < 1.6.2 - Authenticated Stored Cross-Site Scripting (XSS) CVSS 3.1MEDIUM 5.4
  • TI-2021-03269 WP Prayer <= 1.6.5 - Cross-Site Request Forgery Bypass CVSS 3.1MEDIUM 4.3

Sources