Read the docs
TI-2021-03306 Aliases CVE-2021-4450GHSA-w36w-mmqg-xf3r

Post Grid <= 2.1.12 - Contributor+ SQL Injection

Priority MEDIUM 41CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-89.

Summary

The Post Grid plugin for WordPress is vulnerable to blind SQL Injection via post metadata in versions up to, and including, 2.1.12 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers with contributor-level permissions and above to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00486 42nd percentileScored 2026-11-07
Fix Fixed Post Grid (pickplugins): 2.1.13

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
PickPluginsPost Gridbefore 2.1.132.1.13Patch availableCNA
  • Post Grid VendorPickPlugins Affected before 2.1.13 Fixed in 2.1.13 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:pickplugins:post_grid:*:*:*:*:*:wordpress:*:*up to 2.1.12VulnerablePickPlugins
  • cpe:2.3:a:pickplugins:post_grid:*:*:*:*:*:wordpress:*:* Versions up to 2.1.12 Vulnerable ·PickPlugins

Remediation

  • Fix · CNA Post Grid (pickplugins) Fixed in 2.1.13

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-4450
  2. 2026-10-03 Alias added: GHSA-w36w-mmqg-xf3r

References

  • TI-2024-08948 Post Grid and Gutenberg Blocks < 2.2.93 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
  • TI-2024-00811 Combo Blocks < 2.2.76 - Unauthenticated Password Protected Posts Access CVSS 3.1MEDIUM 5.4
  • TI-2024-07651 Post Grid and Gutenberg Blocks 2.2.87 - 2.2.90 - Authenticated (Subscriber+) Privilege Escalation CVSS 3.1HIGH 8.8
  • TI-2020-18382 PHP Object injection vulnerabilities in the Team Showcase plugin before 1.22.16 for… CVSS 3.1HIGH 8.8
  • TI-2020-18381 PHP Object injection vulnerabilities in the Post Grid plugin before 2.0.73 for WordPress… CVSS 3.1HIGH 8.8
  • TI-2024-12450 Post Grid, Slider & Carousel Ultimate – with Shortcode, Gutenberg Block & Elementor… CVSS 3.1HIGH 8.8
See all 13 →

Sources