Post Grid and Gutenberg Blocks < 2.2.93 - Contributor+ Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Post Grid, Posts Slider, Posts Carousel, Post Filter, Post Masonry WordPress plugin before 2.2.93 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Post Grid, Posts Slider, Posts Carousel, Post Filter, Post Masonry | before 2.2.93 | 2.2.93 | Patch available | CNA |
- Post Grid, Posts Slider, Posts Carousel, Post Filter, Post Masonry VendorUnknown Affected before 2.2.93 Fixed in 2.2.93 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pickplugins:post_grid:*:*:*:*:*:wordpress:*:* | before 2.2.93 | Vulnerable | PickPlugins |
- cpe:2.3:a:pickplugins:post_grid:*:*:*:*:*:wordpress:*:* Versions before 2.2.93 Vulnerable ·PickPlugins
Remediation
- Fix · CNA Post Grid, Posts Slider, Posts Carousel, Post Filter, Post Masonry (Unknown) Fixed in 2.2.93
Timeline
- 2026-10-02 Threatist record created from CVE-2024-9645
- 2026-10-03 Alias added: GHSA-w4w8-5w5f-5gvr
References
More PickPlugins Post Grid vulnerabilities
- TI-2024-00811 Combo Blocks < 2.2.76 - Unauthenticated Password Protected Posts Access CVSS 3.1MEDIUM 5.4
- TI-2024-07651 Post Grid and Gutenberg Blocks 2.2.87 - 2.2.90 - Authenticated (Subscriber+) Privilege Escalation CVSS 3.1HIGH 8.8
- TI-2020-18382 PHP Object injection vulnerabilities in the Team Showcase plugin before 1.22.16 for… CVSS 3.1HIGH 8.8
- TI-2020-18381 PHP Object injection vulnerabilities in the Post Grid plugin before 2.0.73 for WordPress… CVSS 3.1HIGH 8.8
- TI-2024-12450 Post Grid, Slider & Carousel Ultimate – with Shortcode, Gutenberg Block & Elementor… CVSS 3.1HIGH 8.8
- TI-2021-03306 Post Grid <= 2.1.12 - Contributor+ SQL Injection CVSS 3.1HIGH 8.8
Sources
- CVE-2024-9645 · CVE Program
- CVE-2024-9645 · NVD
- FIRST EPSS
- GHSA-w4w8-5w5f-5gvr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences