Priority MEDIUM 58
The Post Grid, Posts Slider, Posts Carousel, Post Filter, Post Masonry WordPress plugin before 2.2.93 does not validate and escape some of its block options before outputting them back in a page/post where the block is e…
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00318 · Published 2025-05-15 · Fixed in 2.2.93 CWE-79
Priority MEDIUM 58
The Post Grid, Form Maker, Popup Maker, WooCommerce Blocks, Post Blocks, Post Carousel WordPress plugin before 2.2.76 does not have proper authorization, resulting in password protected posts to be displayed in the resul…
CVSS 3.1MEDIUM 5.4· Network · Low privileges · No interaction · EPSS 0.16906 · Published 2024-04-11 · Fixed in 2.2.76
Priority MEDIUM 52
The Post Grid and Gutenberg Blocks plugin for WordPress is vulnerable to privilege escalation in all versions 2.2.87 to 2.2.90.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.09372 · Published 2024-09-11 · No fix listed CWE-266
Priority MEDIUM 42
PHP Object injection vulnerabilities in the Team Showcase plugin before 1.22.16 for WordPress allow remote authenticated attackers to inject arbitrary PHP objects due to insecure unserialization of data supplied in a rem…
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.02108 · Published 2021-01-01 · No fix listed CWE-502
Priority MEDIUM 42
PHP Object injection vulnerabilities in the Post Grid plugin before 2.0.73 for WordPress allow remote authenticated attackers to inject arbitrary PHP objects due to insecure unserialization of data supplied in a remotely…
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.02108 · Published 2021-01-01 · No fix listed CWE-502
Priority MEDIUM 41
The Post Grid, Slider & Carousel Ultimate – with Shortcode, Gutenberg Block & Elementor Widget plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 1.6.10 via the 'theme' attri…
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.00609 · Published 2025-01-24 · No fix listed CWE-98
Priority MEDIUM 41
The Post Grid plugin for WordPress is vulnerable to blind SQL Injection via post metadata in versions up to, and including, 2.1.12 due to insufficient escaping on the user supplied parameter and lack of sufficient prepar…
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.00486 · Published 2024-10-16 · Fixed in 2.1.13 CWE-89
Priority MEDIUM 40
The slider import search feature and tab parameter of the Post Grid WordPress plugin before 2.1.8 settings are not properly sanitised before being output back in the pages, leading to Reflected Cross-Site Scripting issue…
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.11241 · Published 2021-08-02 · Fixed in 2.1.8 CWE-79
Priority LOW 39
The Post Grid and Gutenberg Blocks – ComboBlocks plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.3.6 via the /wp-json/post-grid/v2/get_users REST API This make…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00442 · Published 2025-02-28 · No fix listed CWE-200
Priority LOW 38
Stored Cross-Site Scripting (XSS) vulnerabilities in the Team Showcase plugin before 1.22.16 for WordPress allow remote authenticated attackers to import layouts including JavaScript supplied via a remotely hosted crafte…
CVSS 3.1HIGH 8.0· Network · Low privileges · User interaction · EPSS 0.01671 · Published 2021-01-01 · No fix listed CWE-79
Priority LOW 38
Stored Cross-Site Scripting (XSS) vulnerabilities in the Post Grid plugin before 2.0.73 for WordPress allow remote authenticated attackers to import layouts including JavaScript supplied via a remotely hosted crafted pay…
CVSS 3.1HIGH 8.0· Network · Low privileges · User interaction · EPSS 0.01671 · Published 2021-01-01 · No fix listed CWE-79
Priority LOW 29
The Post Grid WordPress plugin before 2.1.16 does not sanitise and escape the post_types parameter before outputting it back in the response of the post_grid_update_taxonomies_terms_by_posttypes AJAX action, available to…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00641 · Published 2022-04-11 · Fixed in 2.1.16 CWE-79
Priority LOW 29
The Post Grid WordPress plugin before 2.1.16 does not escape the keyword parameter before outputting it back in an attribute, leading to a Reflected Cross-Site Scripting in pages containing a Post Grid with a search form
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.008 · Published 2022-04-11 · Fixed in 2.1.16 CWE-79
Priority LOW 28
The Post Grid, Form Maker, Popup Maker, WooCommerce Blocks, Post Blocks, Post Carousel – Combo Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'tag' attribute in blocks in all versions up…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00263 · Published 2024-06-07 · No fix listed CWE-79