Grav vulnerable to Cross-Site Scripting (XSS) Stored endpoint `/admin/pages/[page]` in Multiples parameters
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
This admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages. Prior to 1.11.0-beta.1, a Stored Cross-Site Scripting (XSS) vulnerability was identified in the /admin/pages/[page] endpoint of the Grav application. This vulnerability allows attackers to inject malicious scripts into the data[header][metadata], data[header][taxonomy][category], and data[header][taxonomy][tag] parameters. These scripts are stored in the page frontmatter and executed automatically whenever the affected page is accessed or rendered in the administrative interface. This vulnerability is fixed in 1.11.0-beta.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| getgrav | grav | before 1.11.0-beta.1 | 1.11.0-beta.1 | Patch available | CNA |
| — | getgrav/grav (Packagist) | before 1.11.0-beta.1 | 1.11.0-beta.1 | Patch available | GHSA-mpjj-4688-3fxg |
- grav Vendorgetgrav Affected before 1.11.0-beta.1 Fixed in 1.11.0-beta.1 Patch available CNA
- getgrav/grav (Packagist) Vendor— Affected before 1.11.0-beta.1 Fixed in 1.11.0-beta.1 Patch available GHSA-mpjj-4688-3fxg
Remediation
- Fix · CNA grav (getgrav) Fixed in 1.11.0-beta.1
- Fix · GHSA-mpjj-4688-3fxg getgrav/grav (Packagist) Fixed in 1.11.0-beta.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-66311
- 2026-10-03 Alias added: GHSA-mpjj-4688-3fxg
References
More getgrav Grav-plugin-admin vulnerabilities
- TI-2021-04523 Unauthenticated Arbitrary YAML Write/Update leads to Code Execution CVSS 3.1CRITICAL 9.8
- TI-2025-40781 Grav Admin Plugin vulnerable to User Enumeration & Email Disclosure CVSS 3.1MEDIUM 6.5
- TI-2025-40782 Cross-site scripting in getgrav grav CVSS 4.0MEDIUM 6.8
- TI-2025-40786 Cross-site scripting in getgrav grav CVSS 4.0MEDIUM 6.2
- TI-2025-40784 Cross-site scripting in getgrav grav CVSS 4.0MEDIUM 6.2
- TI-2025-40783 Cross-site scripting in getgrav grav CVSS 4.0MEDIUM 6.2
Sources
- CVE-2025-66311 · CVE Program
- CVE-2025-66311 · NVD
- FIRST EPSS
- GHSA-mpjj-4688-3fxg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences