Read the docs
TI-2025-40784 Aliases CVE-2025-66310GHSA-7g78-5g5g-mvfj

Cross-site scripting in getgrav grav

Priority MEDIUM 61CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Active
Attack complexity
Low
Attack requirements
None
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

This admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages. Prior to 1.11.0-beta.1, a Stored Cross-Site Scripting (XSS) vulnerability was identified in the /admin/pages/[page] endpoint of the Grav application. This vulnerability allows attackers to inject malicious scripts into the data[header][template] parameter. The script is saved within the page's frontmatter and executed automatically whenever the affected content is rendered in the administrative interface or frontend view. This vulnerability is fixed in 1.11.0-beta.1.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00229 13th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed grav (getgrav): 1.11.0-beta.1getgrav/grav (Packagist): 1.8.0-beta.27

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
getgravgravbefore 1.11.0-beta.11.11.0-beta.1Patch availableCNA
—getgrav/grav (Packagist)before 1.8.0-beta.271.8.0-beta.27Patch availableGHSA-7g78-5g5g-mvfj
  • grav Vendorgetgrav Affected before 1.11.0-beta.1 Fixed in 1.11.0-beta.1 Patch available CNA
  • getgrav/grav (Packagist) Vendor— Affected before 1.8.0-beta.27 Fixed in 1.8.0-beta.27 Patch available GHSA-7g78-5g5g-mvfj

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:getgrav:grav-plugin-admin:*:*:*:*:*:*:*:*up to 1.10.50Vulnerablegetgrav
  • cpe:2.3:a:getgrav:grav-plugin-admin:*:*:*:*:*:*:*:* Versions up to 1.10.50 Vulnerable ·getgrav

Remediation

  • Fix · CNA grav (getgrav) Fixed in 1.11.0-beta.1
  • Fix · GHSA-7g78-5g5g-mvfj getgrav/grav (Packagist) Fixed in 1.8.0-beta.27 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-66310
  2. 2026-10-03 Alias added: GHSA-7g78-5g5g-mvfj

References

  • TI-2021-04523 Unauthenticated Arbitrary YAML Write/Update leads to Code Execution CVSS 3.1CRITICAL 9.8
  • TI-2025-40781 Grav Admin Plugin vulnerable to User Enumeration & Email Disclosure CVSS 3.1MEDIUM 6.5
  • TI-2025-40782 Cross-site scripting in getgrav grav CVSS 4.0MEDIUM 6.8
  • TI-2025-40786 Cross-site scripting in getgrav grav CVSS 4.0MEDIUM 6.2
  • TI-2025-40785 Grav vulnerable to Cross-Site Scripting (XSS) Stored endpoint `/admin/pages/[page]` in Multiples parameters CVSS 4.0MEDIUM 6.2
  • TI-2025-40783 Cross-site scripting in getgrav grav CVSS 4.0MEDIUM 6.2
See all 8 →

Sources