Grav Admin Plugin vulnerable to User Enumeration & Email Disclosure
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-204.
Summary
This admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages. Prior to 1.11.0-beta.1, a user enumeration and email disclosure vulnerability exists in Grav. The "Forgot Password" functionality at /admin/forgot leaks information about valid usernames and their associated email addresses through distinct server responses. This allows an attacker to enumerate users and disclose sensitive email addresses, which can be leveraged for targeted attacks such as password spraying, phishing, or social engineering. This vulnerability is fixed in 1.11.0-beta.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| getgrav | grav | before 1.11.0-beta.1 | 1.11.0-beta.1 | Patch available | CNA |
| — | getgrav/grav (Packagist) | before 1.8.0-beta.27 | 1.8.0-beta.27 | Patch available | GHSA-q3qx-cp62-f6m7 |
- grav Vendorgetgrav Affected before 1.11.0-beta.1 Fixed in 1.11.0-beta.1 Patch available CNA
- getgrav/grav (Packagist) Vendor— Affected before 1.8.0-beta.27 Fixed in 1.8.0-beta.27 Patch available GHSA-q3qx-cp62-f6m7
Remediation
- Fix · CNA grav (getgrav) Fixed in 1.11.0-beta.1
- Fix · GHSA-q3qx-cp62-f6m7 getgrav/grav (Packagist) Fixed in 1.8.0-beta.27 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-66307
- 2026-10-03 Alias added: GHSA-q3qx-cp62-f6m7
References
More getgrav Grav-plugin-admin vulnerabilities
- TI-2021-04523 Unauthenticated Arbitrary YAML Write/Update leads to Code Execution CVSS 3.1CRITICAL 9.8
- TI-2025-40782 Cross-site scripting in getgrav grav CVSS 4.0MEDIUM 6.8
- TI-2025-40786 Cross-site scripting in getgrav grav CVSS 4.0MEDIUM 6.2
- TI-2025-40785 Grav vulnerable to Cross-Site Scripting (XSS) Stored endpoint `/admin/pages/[page]` in Multiples parameters CVSS 4.0MEDIUM 6.2
- TI-2025-40784 Cross-site scripting in getgrav grav CVSS 4.0MEDIUM 6.2
- TI-2025-40783 Cross-site scripting in getgrav grav CVSS 4.0MEDIUM 6.2
Sources
- CVE-2025-66307 · CVE Program
- CVE-2025-66307 · NVD
- FIRST EPSS
- GHSA-q3qx-cp62-f6m7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences