Improper input validation in Dell Integrated Dell Remote Access Controller
Priority LOW 29CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
Dell iDRAC8 versions prior to 2.75.100.75 contain a host header injection vulnerability. A remote unauthenticated attacker may potentially exploit this vulnerability by injecting arbitrary ‘Host’ header values to poison a web-cache or trigger redirections.
Why it matters now
EPSS 0.01026 63rd percentileScored 2026-11-07
Fix Fixed Integrated Dell Remote Access Controller (iDRAC) (Dell): 2.75.100.75
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA Integrated Dell Remote Access Controller (iDRAC) (Dell) Fixed in 2.75.100.75
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21510
- 2026-10-03 Alias added: GHSA-xxm9-gr2r-5m67
References
More Dell Idrac8 Firmware vulnerabilities
- TI-2020-04396 Stack-based buffer overflow in Dell Integrated Dell Remote Access Controller CVSS 3.1CRITICAL 9.8
- TI-2019-02726 Buffer overflow in Dell EMC iDRAC CVSS 3.1CRITICAL 9.8
- TI-2018-01149 iDRAC7/iDRAC8/iDrac9 contains a command injection vulnerability in the SNMP agent. CVSS 3.0HIGH 8.8
- TI-2016-04940 Injection in Dell EMC iDRAC7 and iDRAC8 CVSS 3.0HIGH 8.8
- TI-2018-11252 iDRAC7/iDRAC8/iDRAC9 - Privilege Escalation Vulnerability CVSS 3.0HIGH 8.8
- TI-2018-01148 iDRAC6/iDRAC7/iDRAC8 - Weak CGI session ID vulnerability CVSS 3.0HIGH 7.5
Sources
- CVE-2021-21510 · CVE Program
- CVE-2021-21510 · NVD
- FIRST EPSS
- GHSA-xxm9-gr2r-5m67 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences