Read the docs
TI-2021-06421 Aliases CVE-2021-24129GHSA-mv99-79gw-2g8g

Themify Portfolio Post < 1.1.6 - Authenticated Stored Cross-Site Scripting

Priority LOW 25CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

Unvalidated input and lack of output encoding in the Themify Portfolio Post WordPress plugin, versions before 1.1.6, lead to Stored Cross-Site Scripting (XSS) vulnerabilities allowing low-privileged users (Contributor+) to inject arbitrary JavaScript code or HTML in posts where the Themify Custom Panel is embedded, which could lead to privilege escalation.

Why it matters now

EPSS 0.00658 51st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Themify Portfolio Post (Unknown): 1.1.6

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownThemify Portfolio Post1.1.6 to before 1.1.61.1.6Patch availableCNA
  • Themify Portfolio Post VendorUnknown Affected 1.1.6 to before 1.1.6 Fixed in 1.1.6 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:themify:portfolio_post:*:*:*:*:*:wordpress:*:*before 1.1.6Vulnerablethemifyme
  • cpe:2.3:a:themify:portfolio_post:*:*:*:*:*:wordpress:*:* Versions before 1.1.6 Vulnerable ·themifyme

Remediation

  • Fix · CNA Themify Portfolio Post (Unknown) Fixed in 1.1.6

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24129
  2. 2026-10-03 Alias added: GHSA-mv99-79gw-2g8g
  3. 2026-10-11 EPSS moved to the 50th–90th percentile

References

  • TI-2023-00346 Themify Portfolio Post < 1.2.2 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
  • TI-2022-04079 Themify Portfolio Post < 1.2.1 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
  • TI-2022-00138 Themify Portfolio Post < 1.1.7 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 5.4
  • TI-2022-14487 WordPress Themify Portfolio Post Plugin <= 1.2.4 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.4

Sources