Read the docs
TI-2021-06517 Aliases CVE-2021-24225GHSA-2hmj-h5rh-f294

Advanced Booking Calendar < 1.6.7 - Authenticated Reflected Cross-Site Scripting (XSS)

Priority LOW 26CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The Advanced Booking Calendar WordPress plugin before 1.6.7 did not sanitise the calId GET parameter in the "Seasons & Calendars" page before outputing it in an A tag, leading to a reflected XSS issue

Why it matters now

EPSS 0.00691 53rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Advanced Booking Calendar (Unknown): 1.6.7

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownAdvanced Booking Calendar1.6.7 to before 1.6.71.6.7Patch availableCNA
  • Advanced Booking Calendar VendorUnknown Affected 1.6.7 to before 1.6.7 Fixed in 1.6.7 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:elbtide:advanced_booking_calendar:*:*:*:*:*:wordpress:*:*before 1.6.7VulnerableElbtide
  • cpe:2.3:a:elbtide:advanced_booking_calendar:*:*:*:*:*:wordpress:*:* Versions before 1.6.7 Vulnerable ·Elbtide

Remediation

  • Fix · CNA Advanced Booking Calendar (Unknown) Fixed in 1.6.7

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24225
  2. 2026-10-03 Alias added: GHSA-2hmj-h5rh-f294

References

  • TI-2022-22626 WordPress Advanced Booking Calendar Plugin <= 1.7.1 is vulnerable to SQL Injection CVSS 3.1CRITICAL 10.0
  • TI-2022-00608 Advanced Booking Calendar < 1.7.0 - Unauthenticated SQL Injection CVSS 3.1CRITICAL 9.8
  • TI-2022-00905 Advanced Booking Calendar < 1.7.1 - Admin+ SQLi CVSS 3.1HIGH 7.2
  • TI-2022-00906 Advanced Booking Calendar < 1.7.1 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
  • TI-2022-22628 WordPress Advanced Booking Calendar Plugin <= 1.7.1 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1MEDIUM 6.5
  • TI-2021-06524 Advanced Booking Calendar < 1.6.8 - Authenticated Reflected Cross-Site Scripting (XSS) CVSS 3.1MEDIUM 5.4

Sources