Advanced Booking Calendar < 1.7.1 - Admin+ SQLi
Priority LOW 35CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.
Summary
The Advanced Booking Calendar WordPress plugin before 1.7.1 does not sanitise and escape the id parameter when editing Calendars, which could allow high privilege users such as admin to perform SQL injection attacks
Why it matters now
EPSS 0.01484 74th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Advanced Booking Calendar (Unknown): 1.7.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Advanced Booking Calendar | 1.7.1 to before 1.7.1 | 1.7.1 | Patch available | CNA |
- Advanced Booking Calendar VendorUnknown Affected 1.7.1 to before 1.7.1 Fixed in 1.7.1 Patch available CNA
Remediation
- Fix · CNA Advanced Booking Calendar (Unknown) Fixed in 1.7.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Advanced Booking Calendar 1.7.1
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2022-00906 Advanced Booking Calendar < 1.7.1 - Reflected Cross-Site ScriptingPriority LOW 31
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1006
- 2026-10-03 Alias added: GHSA-wr35-3f65-j6mc
References
More Elbtide Advanced Booking Calendar vulnerabilities
- TI-2022-22626 WordPress Advanced Booking Calendar Plugin <= 1.7.1 is vulnerable to SQL Injection CVSS 3.1CRITICAL 10.0
- TI-2022-00608 Advanced Booking Calendar < 1.7.0 - Unauthenticated SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2022-00906 Advanced Booking Calendar < 1.7.1 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2022-22628 WordPress Advanced Booking Calendar Plugin <= 1.7.1 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1MEDIUM 6.5
- TI-2021-06517 Advanced Booking Calendar < 1.6.7 - Authenticated Reflected Cross-Site Scripting (XSS) CVSS 3.1MEDIUM 5.4
- TI-2021-06524 Advanced Booking Calendar < 1.6.8 - Authenticated Reflected Cross-Site Scripting (XSS) CVSS 3.1MEDIUM 5.4
Sources
- CVE-2022-1006 · CVE Program
- CVE-2022-1006 · NVD
- FIRST EPSS
- GHSA-wr35-3f65-j6mc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences