Read the docs
TI-2022-00608 Aliases CVE-2022-0694GHSA-2j39-64q5-rjfv

Advanced Booking Calendar < 1.7.0 - Unauthenticated SQL Injection

Priority MEDIUM 46CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.

Summary

The Advanced Booking Calendar WordPress plugin before 1.7.0 does not validate and escape the calendar parameter before using it in a SQL statement via the abc_booking_getSingleCalendar AJAX action (available to both unauthenticated and authenticated users), leading to an unauthenticated SQL injection

Why it matters now

EPSS 0.01849 79th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Advanced Booking Calendar (Unknown): 1.7.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownAdvanced Booking Calendar1.7.0 to before 1.7.01.7.0Patch availableCNA
  • Advanced Booking Calendar VendorUnknown Affected 1.7.0 to before 1.7.0 Fixed in 1.7.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:elbtide:advanced_booking_calendar:*:*:*:*:*:wordpress:*:*before 1.7.0VulnerableElbtide
  • cpe:2.3:a:elbtide:advanced_booking_calendar:*:*:*:*:*:wordpress:*:* Versions before 1.7.0 Vulnerable ·Elbtide

Remediation

  • Fix · CNA Advanced Booking Calendar (Unknown) Fixed in 1.7.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-0694
  2. 2026-10-03 Alias added: GHSA-2j39-64q5-rjfv

References

  • TI-2022-22626 WordPress Advanced Booking Calendar Plugin <= 1.7.1 is vulnerable to SQL Injection CVSS 3.1CRITICAL 10.0
  • TI-2022-00905 Advanced Booking Calendar < 1.7.1 - Admin+ SQLi CVSS 3.1HIGH 7.2
  • TI-2022-00906 Advanced Booking Calendar < 1.7.1 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
  • TI-2022-22628 WordPress Advanced Booking Calendar Plugin <= 1.7.1 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1MEDIUM 6.5
  • TI-2021-06517 Advanced Booking Calendar < 1.6.7 - Authenticated Reflected Cross-Site Scripting (XSS) CVSS 3.1MEDIUM 5.4
  • TI-2021-06524 Advanced Booking Calendar < 1.6.8 - Authenticated Reflected Cross-Site Scripting (XSS) CVSS 3.1MEDIUM 5.4

Sources