Read the docs
TI-2021-06526 Aliases CVE-2021-24234GHSA-6g4w-5pr9-j65h

Ivory Search < 4.6.1 - Reflected Cross Site Scripting (XSS)

Priority LOW 30CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The Search Forms page of the Ivory Search WordPress lugin before 4.6.1 did not properly sanitise the tab parameter before output it in the page, leading to a reflected Cross-Site Scripting issue when opening a malicious crafted link as a high privilege user. Knowledge of a form id is required to conduct the attack.

Why it matters now

EPSS 0.01173 67th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Ivory Search – WordPress Search Plugin (Unknown): 4.6.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownIvory Search – WordPress Search Plugin4.6.1 to before 4.6.14.6.1Patch availableCNA
  • Ivory Search – WordPress Search Plugin VendorUnknown Affected 4.6.1 to before 4.6.1 Fixed in 4.6.1 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:ivorysearch:ivory_search:*:*:*:*:*:wordpress:*:*before 4.6.1VulnerableIvory Search
  • cpe:2.3:a:ivorysearch:ivory_search:*:*:*:*:*:wordpress:*:* Versions before 4.6.1 Vulnerable ·Ivory Search

Remediation

  • Fix · CNA Ivory Search – WordPress Search Plugin (Unknown) Fixed in 4.6.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24234
  2. 2026-10-03 Alias added: GHSA-6g4w-5pr9-j65h

References

  • TI-2025-04675 Ivory Search < 5.5.10 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2024-06338 Ivory Search – WordPress Search Plugin <= 5.5.6 - Information Exposure via AJAX Search Form CVSS 3.1MEDIUM 5.3
  • TI-2021-14961 WordPress Ivory Search plugin <= 4.6.6 - Reflected Cross-Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.1
  • TI-2021-07383 Ivory Search < 5.4.1 - Multiple Admin+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8

Sources