Ivory Search < 5.4.1 - Multiple Admin+ Stored Cross-Site Scripting
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Ivory Search WordPress plugin before 5.4.1 does not escape some of the Form settings, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Why it matters now
EPSS 0.00598 48th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Ivory Search – WordPress Search Plugin (Unknown): 5.4.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Ivory Search – WordPress Search Plugin | 5.4.1 to before 5.4.1 | 5.4.1 | Patch available | CNA |
- Ivory Search – WordPress Search Plugin VendorUnknown Affected 5.4.1 to before 5.4.1 Fixed in 5.4.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ivorysearch:ivory_search:*:*:*:*:*:wordpress:*:* | before 5.4.1 | Vulnerable | Ivory Search |
- cpe:2.3:a:ivorysearch:ivory_search:*:*:*:*:*:wordpress:*:* Versions before 5.4.1 Vulnerable ·Ivory Search
Remediation
- Fix · CNA Ivory Search – WordPress Search Plugin (Unknown) Fixed in 5.4.1
Timeline
- 2026-10-02 Threatist record created from CVE-2021-25105
- 2026-10-03 Alias added: GHSA-mr9w-hm8q-hjg9
References
More Ivory Search vulnerabilities
- TI-2025-04675 Ivory Search < 5.5.10 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2024-06338 Ivory Search – WordPress Search Plugin <= 5.5.6 - Information Exposure via AJAX Search Form CVSS 3.1MEDIUM 5.3
- TI-2021-06526 Ivory Search < 4.6.1 - Reflected Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.1
- TI-2021-14961 WordPress Ivory Search plugin <= 4.6.6 - Reflected Cross-Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.1
Sources
- CVE-2021-25105 · CVE Program
- CVE-2021-25105 · NVD
- FIRST EPSS
- GHSA-mr9w-hm8q-hjg9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences