Read the docs
TI-2021-06533 Aliases CVE-2021-24241GHSA-qrc3-2vgc-v73w

Advanced Custom Field Pro < 5.9.1 - Reflected Cross-Site Scripting (XSS)

Priority LOW 30CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The Advanced Custom Fields Pro WordPress plugin before 5.9.1 did not properly escape the generated update URL when outputting it in an attribute, leading to a reflected Cross-Site Scripting issue in the update settings page.

Why it matters now

EPSS 0.01387 72nd percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed Advanced Custom Fields Pro (Unknown): 5.9.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownAdvanced Custom Fields Pro5.9.1 to before 5.9.15.9.1Patch availableCNA
  • Advanced Custom Fields Pro VendorUnknown Affected 5.9.1 to before 5.9.1 Fixed in 5.9.1 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:advancedcustomfields:advanced_custom_fields:*:*:*:*:pro:wordpress:*:*before 5.9.1VulnerableAdvanced Custom Fields
  • cpe:2.3:a:advancedcustomfields:advanced_custom_fields:*:*:*:*:pro:wordpress:*:* Versions before 5.9.1 Vulnerable ·Advanced Custom Fields

Remediation

  • Fix · CNA Advanced Custom Fields Pro (Unknown) Fixed in 5.9.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24241
  2. 2026-10-03 Alias added: GHSA-qrc3-2vgc-v73w

References

  • TI-2023-01131 Advanced Custom Fields - Contributor+ PHP Object Injection CVSS 3.1HIGH 8.8
  • TI-2024-04251 Advanced Custom Fields < 6.3 - Contributor+ Custom Field Access CVSS 3.1HIGH 7.5
  • TI-2024-08839 Secure Custom Fields < 6.3.6.3 - Admin+ Remote Code Execution CVSS 3.1MEDIUM 6.6
  • TI-2023-14589 WordPress Advanced Custom Fields / Advanced Custom Fields PRO plugins <= 6.1.5 vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
  • TI-2022-02396 Advanced Custom Fields 5.0-5.12.2 - Unauthenticated File Upload CVSS 3.1HIGH 8.8
  • TI-2022-19331 WordPress Advanced Custom Fields Plugin 3.1.1-6.0.2 is vulnerable to Sensitive Data Exposure CVSS 3.1HIGH 7.5
See all 14 →

Sources