Essential Addons for Elementor < 4.5.4 - Contributor+ Stored Cross-Site Scripting (XSS)
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Essential Addons for Elementor Lite WordPress Plugin before 4.5.4 has two widgets that are vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users such as contributors, both via a similar method.
Why it matters now
EPSS 0.0059 48th percentileScored 2026-11-07
Fix Fixed Essential Addons for Elementor (Unknown): 4.5.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Essential Addons for Elementor | 4.5.4 to before 4.5.4 | 4.5.4 | Patch available | CNA |
- Essential Addons for Elementor VendorUnknown Affected 4.5.4 to before 4.5.4 Fixed in 4.5.4 Patch available CNA
Remediation
- Fix · CNA Essential Addons for Elementor (Unknown) Fixed in 4.5.4
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24255
- 2026-10-03 Alias added: GHSA-fvwh-f8rp-cqjc
References
More wpdevteam Essential Addons For Elementor vulnerabilities
- TI-2023-15541 WordPress Essential Addons for Elementor Plugin 5.4.0-5.7.1 is vulnerable to Privilege Escalation CVSS 3.1CRITICAL 9.8
- TI-2022-00249 Essential Addons for Elementor < 5.0.5 - Unauthenticated LFI CVSS 3.1CRITICAL 9.8
- TI-2024-02825 Essential Addons for Elementor <= 5.9.13 - Authenticated (Author+) PHP Object Injection via error_resetpassword CVSS 3.1HIGH 8.8
- TI-2023-22340 WordPress Essential Addons for Elementor plugin <= 5.8.8 - Contributor+ Privilege Escalation vulnerability CVSS 3.1HIGH 8.8
- TI-2021-03303 Essential Addons for Elementor <= 4.6.4 - Authenticated (Contributor+) Privilege Escalation CVSS 3.1HIGH 8.8
- TI-2023-15543 WordPress Essential Addons for Elementor Pro Plugin <= 5.4.8 is vulnerable to Server Side Request Forgery (SSRF) CVSS 3.1HIGH 8.8
Sources
- CVE-2021-24255 · CVE Program
- CVE-2021-24255 · NVD
- FIRST EPSS
- GHSA-fvwh-f8rp-cqjc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences