Youzify < 1.0.7 - Stored Cross-Site Scripting via Biography
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The About Me widget of the Youzify – BuddyPress Community, User Profile, Social Network & Membership WordPress plugin before 1.0.7 does not properly sanitise its Biography field, allowing any authenticated user to set Cross-Site Scripting payloads in it, which will be executed when viewing the affected user profile. This could allow a low privilege user to gain unauthorised access to the admin side of the blog by targeting an admin, inducing them to view their profile with a malicious payload adding a rogue account for example.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Youzify – BuddyPress Community, User Profile, Social Network & Membership Plugin for WordPress | 1.0.7 to before 1.0.7 | 1.0.7 | Patch available | CNA |
- Youzify – BuddyPress Community, User Profile, Social Network & Membership Plugin for WordPress VendorUnknown Affected 1.0.7 to before 1.0.7 Fixed in 1.0.7 Patch available CNA
Remediation
- Fix · CNA Youzify – BuddyPress Community, User Profile, Social Network & Membership Plugin for WordPress (Unknown) Fixed in 1.0.7
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24443
- 2026-10-03 Alias added: GHSA-w5vh-q269-m424
References
More Youzify vulnerabilities
- TI-2023-00055 Youzify < 1.2.2 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2022-01809 Youzify < 1.2.0 - Unauthenticated SQLi CVSS 3.1CRITICAL 9.8
- TI-2024-04415 SQL injection in Youzify – BuddyPress Community, User Profile, Social Network &… CVSS 3.1HIGH 8.8
- TI-2024-24998 WordPress Youzify plugin <= 1.2.5 - SQL Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2024-26559 WordPress Youzify plugin <= 1.2.6 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2024-02674 WordPress Youzify - Buddypress Moderation plugin <= 1.2.5 - Unauthenticated Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.3
Sources
- CVE-2021-24443 · CVE Program
- CVE-2021-24443 · NVD
- FIRST EPSS
- GHSA-w5vh-q269-m424 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences