Read the docs
TI-2021-06748 Aliases CVE-2021-24459GHSA-3wmq-8jfx-8qrm

Survey Maker < 1.5.6 - Authenticated Blind SQL Injections

Priority MEDIUM 41CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.

Summary

The get_results() and get_items() functions in the Survey Maker WordPress plugin before 1.5.6 did not use whitelist or validate the orderby parameter before using it in SQL statements passed to the get_results() DB calls, leading to SQL injection issues in the admin dashboard

Why it matters now

EPSS 0.01362 71st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Survey Maker (Ays Pro): 1.5.6

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Ays ProSurvey Maker1.5.6 to before 1.5.61.5.6Patch availableCNA
  • Survey Maker VendorAys Pro Affected 1.5.6 to before 1.5.6 Fixed in 1.5.6 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:ays-pro:survey_maker:*:*:*:*:*:wordpress:*:*before 1.5.6VulnerableAys Pro
  • cpe:2.3:a:ays-pro:survey_maker:*:*:*:*:*:wordpress:*:* Versions before 1.5.6 Vulnerable ·Ays Pro

Remediation

  • Fix · CNA Survey Maker (Ays Pro) Fixed in 1.5.6

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24459
  2. 2026-10-03 Alias added: GHSA-3wmq-8jfx-8qrm

References

  • TI-2023-09325 SQL injection in Survey Maker WordPress Plugin CVSS 3.1HIGH 8.8
  • TI-2023-02404 Survey Maker < 3.4.7 - Reflected XSS CVSS 3.1MEDIUM 6.1
  • TI-2023-08872 WordPress Survey Maker plugin <= 3.2.0 - Broken Access Control vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2023-00036 Survey Maker – Best WordPress Survey Plugin <= 3.1.3 - Unauthenticated Stored Cross-Site Scripting CVSS 3.1HIGH 7.2
  • TI-2024-19685 WordPress Survey Maker plugin <= 4.0.6 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
  • TI-2023-17858 Insufficient verification of data authenticity in Ays Pro Survey Maker CVSS 3.1MEDIUM 5.3
See all 15 →

Sources