Read the docs
TI-2023-17858 Aliases CVE-2023-35764GHSA-mfh5-9vgh-ffpg

Insufficient verification of data authenticity in Ays Pro Survey Maker

Priority LOW 30CWE-345Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-345.

Summary

Insufficient verification of data authenticity issue in Survey Maker prior to 3.6.4 allows a remote unauthenticated attacker to spoof an IP address when posting.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00263 18th percentileScored 2026-11-07
Fix Fixed Survey Maker (AYS Pro Plugins): 4.1.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Ays ProSurvey Makerbefore 4.1.04.1.0Patch availableCNA
  • Survey Maker VendorAys Pro Affected before 4.1.0 Fixed in 4.1.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:ays-pro:survey_maker:*:*:*:*:*:wordpress:*:*before 3.6.4VulnerableAys Pro
  • cpe:2.3:a:ays-pro:survey_maker:*:*:*:*:*:wordpress:*:* Versions before 3.6.4 Vulnerable ·Ays Pro

Remediation

  • Fix · CNA Survey Maker (AYS Pro Plugins) Fixed in 4.1.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-35764
  2. 2026-10-03 Alias added: GHSA-mfh5-9vgh-ffpg

References

  • TI-2023-09325 SQL injection in Survey Maker WordPress Plugin CVSS 3.1HIGH 8.8
  • TI-2023-02404 Survey Maker < 3.4.7 - Reflected XSS CVSS 3.1MEDIUM 6.1
  • TI-2023-08872 WordPress Survey Maker plugin <= 3.2.0 - Broken Access Control vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2021-06748 Survey Maker < 1.5.6 - Authenticated Blind SQL Injections CVSS 3.1HIGH 8.8
  • TI-2023-00036 Survey Maker – Best WordPress Survey Plugin <= 3.1.3 - Unauthenticated Stored Cross-Site Scripting CVSS 3.1HIGH 7.2
  • TI-2024-19685 WordPress Survey Maker plugin <= 4.0.6 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
See all 15 →

Sources