Survey Maker < 3.4.7 - Reflected XSS
Priority MEDIUM 60Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Survey Maker WordPress plugin before 3.4.7 does not escape some parameters before outputting them back in attributes, leading to Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00458 39th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Survey Maker (Unknown): 3.4.7
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Survey Maker | before 3.4.7 | 3.4.7 | Patch available | CNA |
- Survey Maker VendorUnknown Affected before 3.4.7 Fixed in 3.4.7 Patch available CNA
Remediation
- Fix · CNA Survey Maker (Unknown) Fixed in 3.4.7
Timeline
- 2026-10-02 Threatist record created from CVE-2023-2572
- 2026-10-03 Alias added: GHSA-xx4c-xhpg-hcw2
References
More Ays Pro Survey Maker vulnerabilities
- TI-2023-09325 SQL injection in Survey Maker WordPress Plugin CVSS 3.1HIGH 8.8
- TI-2023-08872 WordPress Survey Maker plugin <= 3.2.0 - Broken Access Control vulnerability CVSS 3.1CRITICAL 9.8
- TI-2021-06748 Survey Maker < 1.5.6 - Authenticated Blind SQL Injections CVSS 3.1HIGH 8.8
- TI-2023-00036 Survey Maker – Best WordPress Survey Plugin <= 3.1.3 - Unauthenticated Stored Cross-Site Scripting CVSS 3.1HIGH 7.2
- TI-2024-19685 WordPress Survey Maker plugin <= 4.0.6 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2023-17858 Insufficient verification of data authenticity in Ays Pro Survey Maker CVSS 3.1MEDIUM 5.3
Sources
- CVE-2023-2572 · CVE Program
- CVE-2023-2572 · NVD
- FIRST EPSS
- GHSA-xx4c-xhpg-hcw2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences