SQL injection in Survey Maker WordPress Plugin
Priority HIGH 79CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-89.
Summary
The Survey Maker WordPress Plugin, version < 3.1.2, is affected by an authenticated SQL injection vulnerability in the 'surveys_ids' parameter of its 'ays_surveys_export_json' action.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.02365 83rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Survey Maker WordPress Plugin: 3.1.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Survey Maker WordPress Plugin | before 3.1.2 | 3.1.2 | Patch available | CNA |
- Survey Maker WordPress Plugin Vendor— Affected before 3.1.2 Fixed in 3.1.2 Patch available CNA
Remediation
- Fix · CNA Survey Maker WordPress Plugin Fixed in 3.1.2
Timeline
- 2026-10-02 Threatist record created from CVE-2023-23490
- 2026-10-03 Alias added: GHSA-rhcg-3p4c-647v
References
More Ays Pro Survey Maker vulnerabilities
- TI-2023-02404 Survey Maker < 3.4.7 - Reflected XSS CVSS 3.1MEDIUM 6.1
- TI-2023-08872 WordPress Survey Maker plugin <= 3.2.0 - Broken Access Control vulnerability CVSS 3.1CRITICAL 9.8
- TI-2021-06748 Survey Maker < 1.5.6 - Authenticated Blind SQL Injections CVSS 3.1HIGH 8.8
- TI-2023-00036 Survey Maker – Best WordPress Survey Plugin <= 3.1.3 - Unauthenticated Stored Cross-Site Scripting CVSS 3.1HIGH 7.2
- TI-2024-19685 WordPress Survey Maker plugin <= 4.0.6 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2023-17858 Insufficient verification of data authenticity in Ays Pro Survey Maker CVSS 3.1MEDIUM 5.3
Sources
- CVE-2023-23490 · CVE Program
- CVE-2023-23490 · NVD
- FIRST EPSS
- GHSA-rhcg-3p4c-647v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences