Read the docs
TI-2021-06770 Aliases CVE-2021-24483GHSA-2fgg-h7jw-4j9r

Poll Maker < 3.2.1 - Authenticated Blind SQL Injections

Priority LOW 34CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.

Summary

The get_poll_categories(), get_polls() and get_reports() functions in the Poll Maker WordPress plugin before 3.2.1 did not use whitelist or validate the orderby parameter before using it in SQL statements passed to the get_results() DB calls, leading to SQL injection issues in the admin dashboard

Why it matters now

EPSS 0.01409 72nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Poll Maker (Ays Pro): 3.2.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Ays ProPoll Maker3.2.1 to before 3.2.13.2.1Patch availableCNA
  • Poll Maker VendorAys Pro Affected 3.2.1 to before 3.2.1 Fixed in 3.2.1 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:ays-pro:poll_maker:*:*:*:*:*:wordpress:*:*before 3.2.1VulnerableAys Pro
  • cpe:2.3:a:ays-pro:poll_maker:*:*:*:*:*:wordpress:*:* Versions before 3.2.1 Vulnerable ·Ays Pro

Remediation

  • Fix · CNA Poll Maker (Ays Pro) Fixed in 3.2.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24483
  2. 2026-10-03 Alias added: GHSA-2fgg-h7jw-4j9r

References

  • TI-2024-12643 Poll Maker < 5.5.4 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2025-18294 WordPress Poll Maker plugin <= 5.5.0 - Broken Access Control vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2025-19842 WordPress Poll Maker <= 5.6.5 - SQL Injection vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2025-30042 WordPress Poll Maker plugin <= 5.7.7 - Race Condition Vulnerability CVSS 3.1HIGH 8.1
  • TI-2023-16880 WordPress Poll Maker Plugin <= 4.6.2 is vulnerable to Server Side Request Forgery (SSRF) CVSS 3.1HIGH 7.5
  • TI-2021-06933 Poll Maker < 3.4.2 - Unauthenticated Time Based SQL Injection CVSS 3.1HIGH 7.5
See all 19 →

Sources