Read the docs
TI-2021-07171 Aliases CVE-2021-24891GHSA-26jf-gmgg-9m8f

Elementor < 3.4.8 - DOM Cross-Site-Scripting

Priority MEDIUM 50CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The Elementor Website Builder WordPress plugin before 3.4.8 does not sanitise or escape user input appended to the DOM via a malicious hash, resulting in a DOM Cross-Site Scripting issue.

Why it matters now

EPSS 0.28862 98th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed Elementor Website Builder (Unknown): 3.4.8

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownElementor Website Builder3.4.8 to before 3.4.83.4.8Patch availableCNA
  • Elementor Website Builder VendorUnknown Affected 3.4.8 to before 3.4.8 Fixed in 3.4.8 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:elementor:website_builder:*:*:*:*:*:wordpress:*:*after 1.5.0, before 3.1.4; 3.2.0 to before 3.4.8VulnerableElementor
  • cpe:2.3:a:elementor:website_builder:*:*:*:*:*:wordpress:*:* Versions after 1.5.0, before 3.1.4; 3.2.0 to before 3.4.8 Vulnerable ·Elementor

Remediation

  • Fix · CNA Elementor Website Builder (Unknown) Fixed in 3.4.8

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24891
  2. 2026-10-03 Alias added: GHSA-26jf-gmgg-9m8f

References

  • TI-2022-01211 Elementor Website Builder 3.6.0 - 3.6.2 - Missing Authorization to Remote Code Execution CVSS 3.1HIGH 8.8
  • TI-2023-00313 Elementor Website Builder < 3.12.2 - Admin+ SQLi CVSS 3.1HIGH 7.2
  • TI-2023-25675 WordPress Elementor plugin <= 3.16.4 - Auth. Arbitrary Attachment Read vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2023-26607 WordPress Elementor plugin 3.3.0-3.18.1 - Arbitrary File Upload vulnerability CVSS 3.1CRITICAL 9.9
  • TI-2023-25676 WordPress Elementor Website Builder Plugin <= 3.16.4 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
  • TI-2022-11925 WordPress Elementor plugin <= 3.5.5 - Unauthenticated DOM-based Reflected Cross-Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.1
See all 36 →

Sources