Read the docs

Elementor

Records83All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical7CVSS 9.0–10.0
CVSS high15CVSS 7.0–8.9

Exploited now

Elementor records in CISA KEV

No Elementor vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

37 records in Website Builder · all components

Priority HIGH 83

The Elementor Website Builder plugin for WordPress is vulnerable to unauthorized execution of several AJAX actions due to a missing capability check in the ~/core/app/modules/onboarding/module.php file that make it possi…

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.92658 Published 2022-04-19 No fix listed CWE-434
Priority HIGH 67

The Elementor Website Builder WordPress plugin before 3.12.2 does not properly sanitize and escape the Replace URL parameter in the Tools module before using it in a SQL statement, leading to a SQL injection exploitable…

CVSS 3.1HIGH 7.2 Network High privileges No interaction EPSS 0.19695 Published 2023-05-30 Fixed in 3.12.2
Priority MEDIUM 51

Improper Authentication vulnerability in Elementor Elementor Website Builder allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects Elementor Website Builder: from n/a through 3.16.4.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01452 Published 2024-04-24 No fix listed CWE-287
Priority MEDIUM 50

Unrestricted Upload of File with Dangerous Type vulnerability in Elementor.Com Elementor Website Builder.This issue affects Elementor Website Builder: from 3.3.0 through 3.18.1.

CVSS 3.1CRITICAL 9.9 Network Low privileges No interaction EPSS 0.041 Published 2024-03-26 No fix listed CWE-434
Priority MEDIUM 50

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Elementor.Com Elementor allows Cross-Site Scripting (XSS).This issue affects Elementor: from n/a through 3.16.4.

CVSS 3.1MEDIUM 6.5 Network Low privileges User interaction EPSS 0.25337 Published 2023-11-30 No fix listed CWE-79
TI-2021-07171 CVE-2021-24891 · GHSA-26jf-gmgg-9m8f

Elementor < 3.4.8 - DOM Cross-Site-Scripting

Priority MEDIUM 50

The Elementor Website Builder WordPress plugin before 3.4.8 does not sanitise or escape user input appended to the DOM via a malicious hash, resulting in a DOM Cross-Site Scripting issue.

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.28862 Published 2021-11-23 Fixed in 3.4.8 CWE-79
Priority MEDIUM 40

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Elementor Elementor Website Builder allows Manipulating Web Input to File System Calls.This issue affects Elementor Website…

CVSS 3.1HIGH 8.5 Network Low privileges No interaction EPSS 0.00715 Published 2024-05-17 No fix listed CWE-22
TI-2022-04542 CVE-2022-4953 · GHSA-3gvr-rm94-r528

Elementor < 3.5.5 - Iframe Injection

Priority LOW 33

The Elementor Website Builder WordPress plugin before 3.5.5 does not filter out user-controlled URLs from being loaded into the DOM.

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.0341 Published 2023-08-14 Fixed in 3.5.5
Priority LOW 29

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Elementor Elementor Website Builder elementor allows Stored XSS.This issue affects Elementor Website Builder: from n/a…

CVSS 3.1MEDIUM 6.5 Network Low privileges User interaction EPSS 0.00294 Published 2025-02-25 No fix listed CWE-79
Priority LOW 29

The Elementor Website Builder Pro plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.25.10 via the 'elementor-template' shortcode.

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.00312 Published 2025-01-30 No fix listed CWE-200
Priority LOW 29

The Elementor Website Builder – More than Just a Page Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘url’ parameter of the Icon widget in all versions up to, and including, 3.25.7 due…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00395 Published 2024-11-26 No fix listed CWE-79
Priority LOW 29

The Elementor Website Builder – More than Just a Page Builder plugin for WordPress is vulnerable to DOM-Based Stored Cross-Site Scripting via the ‘hover_animation’ parameter in versions up to, and including, 3.21.5 due t…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00401 Published 2024-05-21 No fix listed CWE-79
Priority LOW 29

The Elementor Website Builder – More than Just a Page Builder Pro plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the several parameters in versions up to, and including, 3.21.0 due to insufficient…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00419 Published 2024-05-09 No fix listed CWE-79
Priority LOW 29

The Elementor Website Builder – More than Just a Page Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Path Widget in all versions up to, and including, 3.20.2 due to insufficien…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00462 Published 2024-04-09 No fix listed CWE-79
Priority LOW 29

The Elementor Website Builder – More than Just a Page Builder plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the $instance[alt] parameter in the get_image_alt function in all versions up to, and…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00463 Published 2024-02-20 No fix listed CWE-79
Priority LOW 29

The Elementor Website Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG image uploads in versions up to, and including 2.9.7 This makes it possible for authenticated attackers with the upl…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.0048 Published 2023-06-07 No fix listed CWE-79
Priority LOW 28

The Elementor Website Builder – More Than Just a Page Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'elementor-element' shortcode in all versions up to, and including, 3.29.0…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00193 Published 2025-07-29 No fix listed CWE-79
Priority LOW 28

The Elementor Website Builder – More Than Just a Page Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the border, margin and gap parameters in all versions up to, and including, 3.27.4 due t…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00279 Published 2025-02-20 No fix listed CWE-79
Priority LOW 28

The Elementor Website Builder – More than Just a Page Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Typography Settings in all versions up to, and including, 3.25.9 due to ins…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.0032 Published 2024-12-21 No fix listed CWE-79
Load more
Open these records in search →