Read the docs
TI-2021-07371 Aliases CVE-2021-25093GHSA-4j83-364h-wcgq

Link Library < 7.2.8 - Unauthenticated Arbitrary Links Deletion

Priority LOW 35CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-862.

Summary

The Link Library WordPress plugin before 7.2.8 does not have authorisation in place when deleting links, allowing unauthenticated users to delete arbitrary links via a crafted request

Why it matters now

EPSS 0.01196 68th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Link Library (Unknown): 7.2.8

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownLink Library7.2.8 to before 7.2.87.2.8Patch availableCNA
  • Link Library VendorUnknown Affected 7.2.8 to before 7.2.8 Fixed in 7.2.8 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:ylefebvre:link_library:*:*:*:*:*:wordpress:*:*before 7.2.8Vulnerablejackdewey
  • cpe:2.3:a:ylefebvre:link_library:*:*:*:*:*:wordpress:*:* Versions before 7.2.8 Vulnerable ·jackdewey

Remediation

  • Fix · CNA Link Library (Unknown) Fixed in 7.2.8

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Link Library 7.2.8

    2 records Highest priority Priority LOW 2 LOW

    Other records, highest priority first

    • TI-2021-07370 Link Library < 7.2.8 - Library Settings Reset via CSRFPriority LOW 29

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-25093
  2. 2026-10-03 Alias added: GHSA-4j83-364h-wcgq

References

  • TI-2022-03844 Link Library < 7.4.1 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2024-16389 WordPress Link Library Plugin <= 7.5.13 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2024-01455 Link Library <= 7.6 - Unauthenticated Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.5
  • TI-2024-19297 WordPress Link Library plugin <= 7.6 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
  • TI-2024-25945 WordPress Link Library plugin <= 7.7.1 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
  • TI-2024-23556 WordPress Link Library plugin <= 7.6.3 - Reflected Cross-Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
See all 14 →

Sources