Priority MEDIUM 55
The Link Library WordPress plugin before 7.4.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfilter…
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00475 · Published 2023-01-16 · Fixed in 7.4.1
Priority LOW 37
Cross-Site Request Forgery (CSRF) vulnerability in Yannick Lefebvre Link Library.This issue affects Link Library: from n/a through 7.5.13.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00214 · Published 2024-02-12 · No fix listed CWE-352
Priority LOW 35
The Link Library plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'll_reciprocal' parameter in all versions up to, and including, 7.6 due to insufficient input sanitization and output escaping.
CVSS 3.1MEDIUM 6.5· Network · No auth · No interaction · EPSS 0.00415 · Published 2024-02-20 · No fix listed CWE-79
Priority LOW 35
The Link Library WordPress plugin before 7.2.8 does not have authorisation in place when deleting links, allowing unauthenticated users to delete arbitrary links via a crafted request
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.01196 · Published 2022-02-01 · Fixed in 7.2.8 CWE-862
Priority LOW 32
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Yannick Lefebvre Link Library allows Reflected XSS.This issue affects Link Library: from n/a through 7.6.
CVSS 3.1HIGH 7.1· Network · No auth · User interaction · EPSS 0.00422 · Published 2024-03-19 · No fix listed CWE-79
Priority LOW 31
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Yannick Lefebvre Link Library allows Reflected XSS.This issue affects Link Library: from n/a through 7.7.1.
CVSS 3.1HIGH 7.1· Network · No auth · User interaction · EPSS 0.00353 · Published 2024-07-20 · No fix listed CWE-79
Priority LOW 31
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Yannick Lefebvre Link Library link-library allows Reflected XSS.This issue affects Link Library: from n/a throu…
CVSS 3.1HIGH 7.1· Network · No auth · User interaction · EPSS 0.00327 · Published 2024-06-08 · No fix listed CWE-79
Priority LOW 31
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Yannick Lefebvre Link Library allows Reflected XSS.This issue affects Link Library: from n/a through 7.5.13.
CVSS 3.1HIGH 7.1· Network · No auth · User interaction · EPSS 0.00375 · Published 2024-02-08 · No fix listed CWE-79
Priority LOW 29
The Link Library WordPress plugin before 7.2.8 does not have CSRF check when resetting library settings, allowing attackers to make a logged in admin reset arbitrary settings via a CSRF attack
CVSS 3.1MEDIUM 6.5· Network · No auth · User interaction · EPSS 0.0048 · Published 2022-02-01 · Fixed in 7.2.8 CWE-352
Priority LOW 29
The Link Library WordPress plugin before 7.2.9 does not sanitise and escape the settingscopy parameter before outputting it back in an admin page, leading to a Reflected Cross-Site Scripting
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.008 · Published 2022-02-01 · Fixed in 7.2.9 CWE-79
Priority LOW 28
Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Link Library allows Cross-Site Scripting (XSS).
CVSS 4.0MEDIUM 6.4· Network · No auth · User interaction · EPSS 0.00276 · Published 2026-07-29 · Fixed in 7.9.4 CWE-79
Priority LOW 28
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Yannick Lefebvre Link Library link-library allows Stored XSS.This issue affects Link Library: from n/a through <= 7.8.
CVSS 3.1MEDIUM 6.5· Network · Low privileges · User interaction · EPSS 0.0022 · Published 2025-04-22 · No fix listed CWE-79
Priority LOW 28
The Link Library plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'link-library' shortcode in all versions up to, and including, 7.6.11 due to insufficient input sanitization and output…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00263 · Published 2024-05-08 · No fix listed CWE-79
Priority LOW 27
The Link Library plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'searchll' parameter in all versions up to, and including, 7.7.2 due to insufficient input sanitization and output escaping.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00299 · Published 2025-01-21 · No fix listed CWE-79
Priority LOW 27
The Link Library plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the searchll parameter in all versions up to, and including, 7.6.6 due to insufficient input sanitization and output escaping.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00409 · Published 2024-04-09 · No fix listed CWE-79