Link Library < 7.4.1 - Admin+ Stored XSS
Priority MEDIUM 55Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Link Library WordPress plugin before 7.4.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00475 41st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Link Library (Unknown): 7.4.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Link Library | before 7.4.1 | 7.4.1 | Patch available | CNA |
- Link Library VendorUnknown Affected before 7.4.1 Fixed in 7.4.1 Patch available CNA
Remediation
- Fix · CNA Link Library (Unknown) Fixed in 7.4.1
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4199
- 2026-10-03 Alias added: GHSA-v84j-mc7q-38q3
References
More jackdewey Link Library vulnerabilities
- TI-2024-16389 WordPress Link Library Plugin <= 7.5.13 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2024-01455 Link Library <= 7.6 - Unauthenticated Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.5
- TI-2021-07371 Link Library < 7.2.8 - Unauthenticated Arbitrary Links Deletion CVSS 3.1HIGH 7.5
- TI-2024-19297 WordPress Link Library plugin <= 7.6 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2024-25945 WordPress Link Library plugin <= 7.7.1 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2024-23556 WordPress Link Library plugin <= 7.6.3 - Reflected Cross-Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
Sources
- CVE-2022-4199 · CVE Program
- CVE-2022-4199 · NVD
- FIRST EPSS
- GHSA-v84j-mc7q-38q3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences