GTranslate < 2.9.7 - Reflected Cross-Site Scripting
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Translate WordPress with GTranslate WordPress plugin before 2.9.7 does not sanitise and escape the body parameter in the url_addon/gtranslate-email.php file before outputting it back in the page, leading to a Reflected Cross-Site Scripting issue. Note: exploitation of the issue requires knowledge of the NONCE_SALT and NONCE_KEY
Why it matters now
EPSS 0.00752 55th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Translate WordPress with GTranslate (Unknown): 2.9.7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Translate WordPress with GTranslate | 2.9.7 to before 2.9.7 | 2.9.7 | Patch available | CNA |
- Translate WordPress with GTranslate VendorUnknown Affected 2.9.7 to before 2.9.7 Fixed in 2.9.7 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gtranslate:translate_wordpress_with_gtranslate:*:*:*:*:*:wordpress:*:* | before 2.9.7 | Vulnerable | Gtranslate |
- cpe:2.3:a:gtranslate:translate_wordpress_with_gtranslate:*:*:*:*:*:wordpress:*:* Versions before 2.9.7 Vulnerable ·Gtranslate
Remediation
- Fix · CNA Translate WordPress with GTranslate (Unknown) Fixed in 2.9.7
Timeline
- 2026-10-02 Threatist record created from CVE-2021-25103
- 2026-10-03 Alias added: GHSA-7jjc-885j-6655
References
More Gtranslate Translate Wordpress With Gtranslate vulnerabilities
- TI-2023-04155 Translate WordPress with GTranslate < 3.0.4 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2022-00680 Translate WordPress with GTranslate < 2.9.9 - CSRF to Account Takeover CVSS 3.1HIGH 8.8
- TI-2020-09594 The GTranslate plugin before 2.8.52 for WordPress has Reflected XSS via a crafted link. CVSS 3.1MEDIUM 6.1
Sources
- CVE-2021-25103 · CVE Program
- CVE-2021-25103 · NVD
- FIRST EPSS
- GHSA-7jjc-885j-6655 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences