Translate WordPress with GTranslate < 2.9.9 - CSRF to Account Takeover
Priority LOW 39CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352.
Summary
The Translate WordPress with GTranslate WordPress plugin before 2.9.9 does not have CSRF check in some files, and write debug data such as user's cookies in a publicly accessible file if a specific parameter is used when requesting them. Combining those two issues, an attacker could gain access to a logged in admin cookies by making them open a malicious link or page
Why it matters now
EPSS 0.00612 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Translate WordPress with GTranslate (Unknown): 2.9.9
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Translate WordPress with GTranslate | 2.9.9 to before 2.9.9 | 2.9.9 | Patch available | CNA |
- Translate WordPress with GTranslate VendorUnknown Affected 2.9.9 to before 2.9.9 Fixed in 2.9.9 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gtranslate:translate_wordpress_with_gtranslate:*:*:*:*:*:wordpress:*:* | before 2.9.9 | Vulnerable | Gtranslate |
- cpe:2.3:a:gtranslate:translate_wordpress_with_gtranslate:*:*:*:*:*:wordpress:*:* Versions before 2.9.9 Vulnerable ·Gtranslate
Remediation
- Fix · CNA Translate WordPress with GTranslate (Unknown) Fixed in 2.9.9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0770
- 2026-10-03 Alias added: GHSA-pgcx-vfvx-q6c9
References
More Gtranslate Translate Wordpress With Gtranslate vulnerabilities
- TI-2023-04155 Translate WordPress with GTranslate < 3.0.4 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2020-09594 The GTranslate plugin before 2.8.52 for WordPress has Reflected XSS via a crafted link. CVSS 3.1MEDIUM 6.1
- TI-2021-07381 GTranslate < 2.9.7 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 4.7
Sources
- CVE-2022-0770 · CVE Program
- CVE-2022-0770 · NVD
- FIRST EPSS
- GHSA-pgcx-vfvx-q6c9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences