Read the docs
TI-2023-04155 Aliases CVE-2023-4502GHSA-m4jh-qqmf-7jg2

Translate WordPress with GTranslate < 3.0.4 - Admin+ Stored XSS

Priority MEDIUM 55Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

The Translate WordPress with GTranslate WordPress plugin before 3.0.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup). This vulnerability affects multiple parameters.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0047 40th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Translate WordPress with GTranslate (Unknown): 3.0.4

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownTranslate WordPress with GTranslatebefore 3.0.43.0.4Patch availableCNA
  • Translate WordPress with GTranslate VendorUnknown Affected before 3.0.4 Fixed in 3.0.4 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:gtranslate:translate_wordpress_with_gtranslate:*:*:*:*:*:wordpress:*:*before 3.0.4VulnerableGtranslate
  • cpe:2.3:a:gtranslate:translate_wordpress_with_gtranslate:*:*:*:*:*:wordpress:*:* Versions before 3.0.4 Vulnerable ·Gtranslate

Remediation

  • Fix · CNA Translate WordPress with GTranslate (Unknown) Fixed in 3.0.4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-4502
  2. 2026-10-03 Alias added: GHSA-m4jh-qqmf-7jg2

References

  • TI-2022-00680 Translate WordPress with GTranslate < 2.9.9 - CSRF to Account Takeover CVSS 3.1HIGH 8.8
  • TI-2020-09594 The GTranslate plugin before 2.8.52 for WordPress has Reflected XSS via a crafted link. CVSS 3.1MEDIUM 6.1
  • TI-2021-07381 GTranslate < 2.9.7 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 4.7

Sources