Publify - Improper Authorization Leads to Guest Signup Restriction Bypass
Priority HIGH 68CWE-285Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-285.
Summary
In Publify, 9.0.0.pre1 to 9.2.4 are vulnerable to Improper Access Control. “guest” role users can self-register even when the admin does not allow. This happens due to front-end restriction only.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00827 57th percentileScored 2026-11-07
Fix Fixed publify_core (RubyGems): 9.2.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| publify_core | publify_core | 9.0.0.pre1 and later; up to 9.2.4 | — | No fix listed | CNA |
| — | publify_core (RubyGems) | 9.0.0.pre1 to before 9.2.5 | 9.2.5 | Patch available | GHSA-x24j-87x9-jvv5 |
- publify_core Vendorpublify_core Affected 9.0.0.pre1 and later; up to 9.2.4 Fixed in — No fix listed CNA
- publify_core (RubyGems) Vendor— Affected 9.0.0.pre1 to before 9.2.5 Fixed in 9.2.5 Patch available GHSA-x24j-87x9-jvv5
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:publify_project:publify:*:*:*:*:*:*:*:* | 9.0.0 – 9.2.4 | Vulnerable | publify_core |
- cpe:2.3:a:publify_project:publify:*:*:*:*:*:*:*:* Versions 9.0.0 – 9.2.4 Vulnerable ·publify_core
Remediation
- Fix · GHSA-x24j-87x9-jvv5 publify_core (RubyGems) Fixed in 9.2.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-25973
- 2026-10-03 Alias added: GHSA-x24j-87x9-jvv5
References
Advisory 2
More publify_core Publify vulnerabilities
- TI-2023-00284 Improper Input Validation in publify/publify CVSS 3.1CRITICAL 9.8
- TI-2022-01678 Integer Overflow or Wraparound in publify/publify CVSS 3.1CRITICAL 9.8
- TI-2023-00540 Weak Password Requirements in publify/publify CVSS 3.1MEDIUM 6.5
- TI-2022-02609 Insecure Storage of Sensitive Information in publify/publify CVSS 3.1MEDIUM 6.5
- TI-2021-07981 Publify - Stored Cross-Site Scripting (XSS) due to Unrestricted File Upload CVSS 3.1MEDIUM 5.4
- TI-2021-07980 Publify - Stored Cross-Site Scripting (XSS) in Editor CVSS 3.1MEDIUM 5.4
Sources
- CVE-2021-25973 · CVE Program
- CVE-2021-25973 · NVD
- FIRST EPSS
- GHSA-x24j-87x9-jvv5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences